Tianyi Wang has posted comments on this change. ( 
http://gerrit.cloudera.org:8080/9300 )

Change subject: IMPALA-5690: Part 2: Upgrade thrift to 0.9.3-p3
......................................................................


Patch Set 11:

(1 comment)

http://gerrit.cloudera.org:8080/#/c/9300/11/be/src/rpc/thrift-server-test.cc
File be/src/rpc/thrift-server-test.cc:

http://gerrit.cloudera.org:8080/#/c/9300/11/be/src/rpc/thrift-server-test.cc@362
PS11, Line 362:       {TLSv1_1, {SSLTLS, TLSv1_1}},
> I realized I didn't think it through.
I think if we take option 1, the implementation should be:
When impala initializes, read ssl_minimum_version and disable versions lower 
than the minimum process-wide. Then always use SSLTLS to initialize ssl 
context. This way we don't need to patch thrift. And this test needs to be 
refactored a little.



--
To view, visit http://gerrit.cloudera.org:8080/9300
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-Project: Impala-ASF
Gerrit-Branch: master
Gerrit-MessageType: comment
Gerrit-Change-Id: I639227721502eaa10398d9490ff6ac63aa71b3a6
Gerrit-Change-Number: 9300
Gerrit-PatchSet: 11
Gerrit-Owner: Tianyi Wang <tw...@cloudera.com>
Gerrit-Reviewer: Dan Hecht <dhe...@cloudera.com>
Gerrit-Reviewer: Lars Volker <l...@cloudera.com>
Gerrit-Reviewer: Michael Ho <k...@cloudera.com>
Gerrit-Reviewer: Sailesh Mukil <sail...@cloudera.com>
Gerrit-Reviewer: Thomas Tauber-Marshall <tmarsh...@cloudera.com>
Gerrit-Reviewer: Tianyi Wang <tw...@cloudera.com>
Gerrit-Reviewer: anujphadke <apha...@cloudera.com>
Gerrit-Comment-Date: Wed, 18 Apr 2018 02:25:22 +0000
Gerrit-HasComments: Yes

Reply via email to