Peter Rozsa has posted comments on this change. ( http://gerrit.cloudera.org:8080/24534 )
Change subject: IMPALA-15161: Add GEOMETRY type + make WKB_EXPERIMENTAL default ...................................................................... Patch Set 14: (10 comments) First round of comments, let's work on https://gerrit.cloudera.org/c/24661/ to make this more readable http://gerrit.cloudera.org:8080/#/c/24534/13/be/src/exprs/expr-test.cc File be/src/exprs/expr-test.cc: http://gerrit.cloudera.org:8080/#/c/24534/13/be/src/exprs/expr-test.cc@8722 PS13, Line 8722: (IMPALA-15244) not needed http://gerrit.cloudera.org:8080/#/c/24534/13/be/src/exprs/expr-test.cc@8723 PS13, Line 8723: (Java UDFs) not always true http://gerrit.cloudera.org:8080/#/c/24534/13/bin/start-impala-cluster.py File bin/start-impala-cluster.py: http://gerrit.cloudera.org:8080/#/c/24534/13/bin/start-impala-cluster.py@165 PS13, Line 165: (WKB_EXPERIMENTAL) Let's change just L163, this script is not a budled artifact, it's only a helper for dev/test http://gerrit.cloudera.org:8080/#/c/24534/13/fe/src/compat-hive-3/java/org/apache/impala/compat/HiveEsriGeospatialBuiltins.java File fe/src/compat-hive-3/java/org/apache/impala/compat/HiveEsriGeospatialBuiltins.java: http://gerrit.cloudera.org:8080/#/c/24534/13/fe/src/compat-hive-3/java/org/apache/impala/compat/HiveEsriGeospatialBuiltins.java@64 PS13, Line 64: public class HiveEsriGeospatialBuiltins { This whole class is now ravaged by conditions and branches based on the implementation, is it possible to give dedicated implementations for the 3 different modes now? http://gerrit.cloudera.org:8080/#/c/24534/13/fe/src/compat-hive-3/java/org/apache/impala/compat/HiveEsriGeospatialBuiltins.java@72 PS13, Line 72: private static class BinaryToGeometryHiveLegacyFunctionExtractor BinaryToBinaryHiveLegacyFunctionExtractor is a separate class, it should also be a separate class http://gerrit.cloudera.org:8080/#/c/24534/13/fe/src/main/java/org/apache/impala/analysis/InPredicate.java File fe/src/main/java/org/apache/impala/analysis/InPredicate.java: http://gerrit.cloudera.org:8080/#/c/24534/13/fe/src/main/java/org/apache/impala/analysis/InPredicate.java@a54 PS13, Line 54: it looks unrelated http://gerrit.cloudera.org:8080/#/c/24534/13/fe/src/main/java/org/apache/impala/catalog/BuiltinsDb.java File fe/src/main/java/org/apache/impala/catalog/BuiltinsDb.java: http://gerrit.cloudera.org:8080/#/c/24534/13/fe/src/main/java/org/apache/impala/catalog/BuiltinsDb.java@1709 PS13, Line 1709: // first_value/last_value/lag/lead just copy a value through (no comparison), so It enables an unrelated feature, it could be done separately http://gerrit.cloudera.org:8080/#/c/24534/13/fe/src/test/java/org/apache/impala/analysis/AnalyzeDDLTest.java File fe/src/test/java/org/apache/impala/analysis/AnalyzeDDLTest.java: http://gerrit.cloudera.org:8080/#/c/24534/13/fe/src/test/java/org/apache/impala/analysis/AnalyzeDDLTest.java@3358 PS13, Line 3358: data source type. nit: looks odd http://gerrit.cloudera.org:8080/#/c/24534/13/fe/src/test/java/org/apache/impala/analysis/AnalyzeStmtsTest.java File fe/src/test/java/org/apache/impala/analysis/AnalyzeStmtsTest.java: http://gerrit.cloudera.org:8080/#/c/24534/13/fe/src/test/java/org/apache/impala/analysis/AnalyzeStmtsTest.java@2495 PS13, Line 2495: (BuiltinsDb skips : // it) not needed, AI slop http://gerrit.cloudera.org:8080/#/c/24534/13/tests/custom_cluster/test_geospatial_library.py File tests/custom_cluster/test_geospatial_library.py: http://gerrit.cloudera.org:8080/#/c/24534/13/tests/custom_cluster/test_geospatial_library.py@33 PS13, Line 33: (WKB_EXPERIMENTAL not needed -- To view, visit http://gerrit.cloudera.org:8080/24534 To unsubscribe, visit http://gerrit.cloudera.org:8080/settings Gerrit-Project: Impala-ASF Gerrit-Branch: master Gerrit-MessageType: comment Gerrit-Change-Id: I0ff29cb15ab45f3899bf453041e605a32f195c27 Gerrit-Change-Number: 24534 Gerrit-PatchSet: 14 Gerrit-Owner: Csaba Ringhofer <[email protected]> Gerrit-Reviewer: Arnab Karmakar <[email protected]> Gerrit-Reviewer: Balazs Hevele <[email protected]> Gerrit-Reviewer: Csaba Ringhofer <[email protected]> Gerrit-Reviewer: Impala Public Jenkins <[email protected]> Gerrit-Reviewer: Peter Rozsa <[email protected]> Gerrit-Comment-Date: Mon, 17 Aug 2026 14:42:31 +0000 Gerrit-HasComments: Yes
