Tim Armstrong has uploaded a new change for review.

  http://gerrit.cloudera.org:8080/5314

Change subject: IMPALA-4570: shell tarball breaks with certain setuptools 
versions
......................................................................

IMPALA-4570: shell tarball breaks with certain setuptools versions

The bug was in the third-party pkg_resources.py script. The version
check was broken because it matches any version with a "0.7" substring
instead of just versions starting with 0.7.

This is a known bug. setuptools even re-released 20.7.0 as version
20.8.0 to avoid it:
https://github.com/pypa/setuptools/commit/e5822f0d5be6386bf86cde03988bfdf1bfc2e935

Change-Id: I0565c0e6c1be7d82c3f35d2545ba044a684bb075
---
M shell/pkg_resources.py
1 file changed, 2 insertions(+), 2 deletions(-)


  git pull ssh://gerrit.cloudera.org:29418/Impala-ASF refs/changes/14/5314/1
-- 
To view, visit http://gerrit.cloudera.org:8080/5314
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-MessageType: newchange
Gerrit-Change-Id: I0565c0e6c1be7d82c3f35d2545ba044a684bb075
Gerrit-PatchSet: 1
Gerrit-Project: Impala-ASF
Gerrit-Branch: master
Gerrit-Owner: Tim Armstrong <tarmstr...@cloudera.com>

Reply via email to