anukalp2804 opened a new issue, #17630: URL: https://github.com/apache/iotdb/issues/17630
## Description This PR fixes a SonarCloud, reports a violation of rule `java:S1192`, issue related to duplicated string literals in the TElastic Framed Transport module. The string literal `" from "` was used multiple times. It has been replaced with a constant to improve maintainability and readability. ## Sonar Issue https://sonarcloud.io/project/issues?id=apache_iotdb&pullRequest=17612&issueStatuses=OPEN,CONFIRMED&sinceLeakPeriod=true ## Files modified: `iotdb-client/service-rpc/src/main/java/org/apache/iotdb/rpc/TElasticFramedTransport.java` ## How to fix - Introduced a constant FROM - Replaced all occurrences of " from " with the constant ## Example ```tsx private static final String ACTION = "action"; public void run() { prepare(ACTION); execute(ACTION); release(ACTION); } ``` -- This is an automated message from the Apache Git Service. To respond to the message, please log on to GitHub and use the URL above to go to the specific comment. To unsubscribe, e-mail: [email protected] For queries about this service, please contact Infrastructure at: [email protected]
