Mike Percy has posted comments on this change.

Change subject: [KuduPartialRow::Set{Binary,String}()] copy input data
......................................................................


Patch Set 5:

(2 comments)

http://gerrit.cloudera.org:8080/#/c/3868/5/src/kudu/common/partial_row-test.cc
File src/kudu/common/partial_row-test.cc:

Line 41:       Status (KuduPartialRow::* pmfSetter)(int, const Slice&),
Would you mind using std::function for this? Easier to read. Also, minor style 
nit: don't use camelCaps for variable names.


Line 43:       int column_idx, bool should_copy) {
nit: please use an enum instead of a bool for should_copy, like enum { COPY, 
NO_COPY } or { kShouldCopy, kShouldNotCopy }, something like that. This makes 
it obvious what the parameter meaning is at the call site.


-- 
To view, visit http://gerrit.cloudera.org:8080/3868
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I764339a0e3ffbf6abd5372e682c9fa1792bdd52b
Gerrit-PatchSet: 5
Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-Owner: Alexey Serbin <aser...@cloudera.com>
Gerrit-Reviewer: Adar Dembo <a...@cloudera.com>
Gerrit-Reviewer: Alexey Serbin <aser...@cloudera.com>
Gerrit-Reviewer: Dan Burkert <d...@cloudera.com>
Gerrit-Reviewer: Dinesh Bhat <din...@cloudera.com>
Gerrit-Reviewer: Kudu Jenkins
Gerrit-Reviewer: Mike Percy <mpe...@apache.org>
Gerrit-Reviewer: Todd Lipcon <t...@apache.org>
Gerrit-HasComments: Yes

Reply via email to