David Ribeiro Alves has posted comments on this change.

Change subject: KUDU-1755 Part 2: Improve tablet on-disk size metric
......................................................................


Patch Set 22:

(10 comments)

http://gerrit.cloudera.org:8080/#/c/6968/22/src/kudu/consensus/consensus_meta.h
File src/kudu/consensus/consensus_meta.h:

PS22, Line 159: on_disk_size()
docs


http://gerrit.cloudera.org:8080/#/c/6968/22/src/kudu/consensus/log.cc
File src/kudu/consensus/log.cc:

PS22, Line 914: std::memory_order_relaxed
do we really need to pass a memory ordering directive here?


http://gerrit.cloudera.org:8080/#/c/6968/22/src/kudu/consensus/log.h
File src/kudu/consensus/log.h:

PS22, Line 210: log's current WAL
weird phrasing since WAL is also write-ahead-log (yeah, I know naming sucks 
here). maybe: this log's current segments? or even: "total size of the current 
segments, in bytes"


http://gerrit.cloudera.org:8080/#/c/6968/22/src/kudu/consensus/raft_consensus.h
File src/kudu/consensus/raft_consensus.h:

PS22, Line 328: size on-disk
xxs nit: on-disk size?


http://gerrit.cloudera.org:8080/#/c/6968/22/src/kudu/tablet/cfile_set.h
File src/kudu/tablet/cfile_set.h:

PS22, Line 95: The size on-disk of this cfile set's data, in bytes.
make it explicit that this excludes the (ad-hoc) index and blooms?


http://gerrit.cloudera.org:8080/#/c/6968/22/src/kudu/tablet/diskrowset.cc
File src/kudu/tablet/diskrowset.cc:

PS22, Line 726: OnDiskDataSizeNoUndos
one last thing since you're fixing this. this naming is a bit misleading, maybe 
OnDiskBaseDataSizeWithRedos() would be more accurate.


http://gerrit.cloudera.org:8080/#/c/6968/22/src/kudu/tablet/rowset.h
File src/kudu/tablet/rowset.h:

PS22, Line 131: excluding metadata
maybe be explicit? "excluding bloom filter and ad-hoc index"


PS22, Line 134:  Return the size, in bytes, of this rowset's data, not 
including undo deltas.
this doesn't include the "metadata" either, right?


http://gerrit.cloudera.org:8080/#/c/6968/22/src/kudu/tablet/tablet.h
File src/kudu/tablet/tablet.h:

PS22, Line 242: , but not the consensus metadata
nit I don't think you technically need to mention consensus here, since tablet 
is an orthogonal component to consensus in a sense.


http://gerrit.cloudera.org:8080/#/c/6968/22/src/kudu/tablet/tablet_replica.h
File src/kudu/tablet/tablet_replica.h:

PS22, Line 287: Differs from Tablet::OnDiskSize in that it includes log 
segments and cmeta.
Again, I don't think you need to mention this here, since tablet, along with 
consensus and the log are components of tablet replica.


-- 
To view, visit http://gerrit.cloudera.org:8080/6968
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: Ia83f8aae0a544abbd19f5a34520b4828b89b6315
Gerrit-PatchSet: 22
Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-Owner: Will Berkeley <wdberke...@gmail.com>
Gerrit-Reviewer: Adar Dembo <a...@cloudera.com>
Gerrit-Reviewer: Alexey Serbin <aser...@cloudera.com>
Gerrit-Reviewer: Andrew Wong <aw...@cloudera.com>
Gerrit-Reviewer: David Ribeiro Alves <davidral...@gmail.com>
Gerrit-Reviewer: Kudu Jenkins
Gerrit-Reviewer: Mike Percy <mpe...@apache.org>
Gerrit-Reviewer: Tidy Bot
Gerrit-Reviewer: Todd Lipcon <t...@apache.org>
Gerrit-Reviewer: Will Berkeley <wdberke...@gmail.com>
Gerrit-HasComments: Yes

Reply via email to