Alexey Serbin has posted comments on this change. ( 
http://gerrit.cloudera.org:8080/8717 )

Change subject: [util] operators for MonoDelta addition/subtraction
......................................................................


Patch Set 1:

(4 comments)

http://gerrit.cloudera.org:8080/#/c/8717/1/src/kudu/util/monotime-test.cc
File src/kudu/util/monotime-test.cc:

http://gerrit.cloudera.org:8080/#/c/8717/1/src/kudu/util/monotime-test.cc@295
PS1, Line 295: EXPECT_TRUE
> EXPECT_EQ ?
Done


http://gerrit.cloudera.org:8080/#/c/8717/1/src/kudu/util/monotime.h
File src/kudu/util/monotime.h:

http://gerrit.cloudera.org:8080/#/c/8717/1/src/kudu/util/monotime.h@136
PS1, Line 136:   friend MonoDelta operator-(const MonoDelta&, const MonoDelta&);
             :   friend MonoDelta operator+(const MonoDelta&, const MonoDelta&);
> not needed?
It's needed because those operators use the private constructor of the class: 
MonoDelta(int64_t)


http://gerrit.cloudera.org:8080/#/c/8717/1/src/kudu/util/monotime.h@323
PS1, Line 323: MonoDelta KUDU_EXPORT operator-(const MonoDelta& lhs, const 
MonoDelta& rhs);
> warning: redundant 'operator-' declaration [readability-redundant-declarati
I'm curious what's redundant here?  The previous declaration was in the context 
of the friendship.

I'm going to ignore this clang-tidy warning.


http://gerrit.cloudera.org:8080/#/c/8717/1/src/kudu/util/monotime.h@330
PS1, Line 330: MonoDelta KUDU_EXPORT operator+(const MonoDelta& lhs, const 
MonoDelta& rhs);
> warning: redundant 'operator+' declaration [readability-redundant-declarati
ditto



--
To view, visit http://gerrit.cloudera.org:8080/8717
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-MessageType: comment
Gerrit-Change-Id: Idc1fe1e2dd3b47b6a0d9ef977749c7c27dbf168c
Gerrit-Change-Number: 8717
Gerrit-PatchSet: 1
Gerrit-Owner: Alexey Serbin <aser...@cloudera.com>
Gerrit-Reviewer: Alexey Serbin <aser...@cloudera.com>
Gerrit-Reviewer: Andrew Wong <aw...@cloudera.com>
Gerrit-Reviewer: Kudu Jenkins
Gerrit-Reviewer: Mike Percy <mpe...@apache.org>
Gerrit-Reviewer: Tidy Bot
Gerrit-Comment-Date: Fri, 01 Dec 2017 21:31:55 +0000
Gerrit-HasComments: Yes

Reply via email to