Andrew Wong has posted comments on this change. ( http://gerrit.cloudera.org:8080/15599 )
Change subject: Remove return types from various lambdas ...................................................................... Patch Set 3: Code-Review+2 (1 comment) http://gerrit.cloudera.org:8080/#/c/15599/3/src/kudu/util/threadpool-test.cc File src/kudu/util/threadpool-test.cc: http://gerrit.cloudera.org:8080/#/c/15599/3/src/kudu/util/threadpool-test.cc@777 PS3, Line 777: auto GetRandomToken = [&]() { > Had "tokens" been away from the lambda like a member variable declared in s Yeah, alternatively, this could be made a std::function() so its type is clearly defined, or renamed for clarity, though I'm fine with leaving this as is. -- To view, visit http://gerrit.cloudera.org:8080/15599 To unsubscribe, visit http://gerrit.cloudera.org:8080/settings Gerrit-Project: kudu Gerrit-Branch: master Gerrit-MessageType: comment Gerrit-Change-Id: Idb6cb2570121d47dee15d9e63b677126c30de4f9 Gerrit-Change-Number: 15599 Gerrit-PatchSet: 3 Gerrit-Owner: Adar Dembo <[email protected]> Gerrit-Reviewer: Adar Dembo <[email protected]> Gerrit-Reviewer: Alexey Serbin <[email protected]> Gerrit-Reviewer: Andrew Wong <[email protected]> Gerrit-Reviewer: Bankim Bhavsar <[email protected]> Gerrit-Comment-Date: Mon, 30 Mar 2020 23:21:56 +0000 Gerrit-HasComments: Yes
