-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/32163/#review82410
-----------------------------------------------------------



3rdparty/libprocess/3rdparty/stout/include/stout/json.hpp
<https://reviews.apache.org/r/32163/#comment133138>

    s/Note/NOTE/



3rdparty/libprocess/3rdparty/stout/tests/json_tests.cpp
<https://reviews.apache.org/r/32163/#comment133144>

    How about testing that it doesn't match a string?



3rdparty/libprocess/3rdparty/stout/tests/json_tests.cpp
<https://reviews.apache.org/r/32163/#comment133149>

    I start to think it makes sense to break this test up in sub tests for the 
value types. What do you think?



3rdparty/libprocess/3rdparty/stout/tests/json_tests.cpp
<https://reviews.apache.org/r/32163/#comment133150>

    Want to test strings too?



3rdparty/libprocess/3rdparty/stout/tests/json_tests.cpp
<https://reviews.apache.org/r/32163/#comment133151>

    Same question: want to check that it doesn't match a string?



3rdparty/libprocess/3rdparty/stout/tests/json_tests.cpp
<https://reviews.apache.org/r/32163/#comment133152>

    Want to check that it doesn't match an array?



3rdparty/libprocess/3rdparty/stout/tests/json_tests.cpp
<https://reviews.apache.org/r/32163/#comment133174>

    should 'json' be capitalized in our comments?


- Niklas Nielsen


On May 1, 2015, 11:55 a.m., Alexander Rojas wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/32163/
> -----------------------------------------------------------
> 
> (Updated May 1, 2015, 11:55 a.m.)
> 
> 
> Review request for mesos, Benjamin Hindman, Bernd Mathiske, Joerg Schad, 
> Marco Massenzio, Niklas Nielsen, and Till Toenshoff.
> 
> 
> Bugs: MESOS-2510
>     https://issues.apache.org/jira/browse/MESOS-2510
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Adds a function which allows to perform comparison tests on subsets of json 
> blobs. i.e.
> 
> ```cpp
> JSON::Value expected = JSON::parse(
>     "{"
>     "  \"key\" : true"
>       "}").get();
> 
> // Returned json:
> // {
> //   "uptime" : 45234.123,
> //   "key" : true
> // }
> JSON::Value actual = bar();
> 
> // I'm only interested on the "key" entry and ignore the rest.
> EXPECT_TRUE(contains(actual, expected));
> ```
> 
> Increasing readability for tests that include json.
> 
> For more information on the reason of why this patch is needed, please check 
> the JIRA entry.
> 
> 
> Diffs
> -----
> 
>   3rdparty/libprocess/3rdparty/stout/include/stout/json.hpp 
> 334c898906018be6e663f53815abbe047806b95c 
>   3rdparty/libprocess/3rdparty/stout/tests/json_tests.cpp 
> f60d1bbe60f2e2b6460c06bba98e8b85ebb6a3f9 
> 
> Diff: https://reviews.apache.org/r/32163/diff/
> 
> 
> Testing
> -------
> 
> make check
> 
> 
> Thanks,
> 
> Alexander Rojas
> 
>

Reply via email to