> On June 9, 2015, 10:36 a.m., Niklas Nielsen wrote:
> > src/master/master.cpp, lines 3513-3514
> > <https://reviews.apache.org/r/35118/diff/1/?file=980131#file980131line3513>
> >
> >     Does it make sense to point to some documentation (if it exists 
> > already, or inline) about how this resource math will work?
> 
> Jiang Yan Xu wrote:
>     Can you suggest something here?
>     
>     FWIW I also updated the comment on `totalResources`:
>     ```
>       // The current total resources of the slave. Note that this is
>       // different from 'info.resources()' because this also considers
>       // operations (e.g., CREATE, RESERVE) that have been applied and
>       // includes revocable resources as well.
>       Resources totalResources;
>     ```
> 
> Ben Mahler wrote:
>     Given the check above, how about calling .revocable to make it symmetric:
>     
>     ```
>       slave->totalResources -= slave->totalResources.revocable();
>       slave->totalResources += oversubscribedResources.revocable();
>     ```
>     
>     Should be a bit clearer to the reader that what we're doing here is 
> updating the revocable resources, without needing a big comment.

SGTM. Will do.


- Jiang Yan


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/35118/#review87234
-----------------------------------------------------------


On June 5, 2015, 2:09 p.m., Jiang Yan Xu wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/35118/
> -----------------------------------------------------------
> 
> (Updated June 5, 2015, 2:09 p.m.)
> 
> 
> Review request for mesos and Vinod Kone.
> 
> 
> Bugs: MESOS-2776
>     https://issues.apache.org/jira/browse/MESOS-2776
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> - This way Master::Slave::totalResources includes revocable resources, which 
> we need for metrics for revocable resources.
> - Changed updateSlave() argument to use `const Resources& 
> oversubscribedResources` instead of `const std::vector<Resource>& 
> oversubscribedResources` because `Resources` provides convenience methods 
> such as `revocable()`.
> 
> 
> Diffs
> -----
> 
>   src/master/master.hpp deeb0d8c87a13315206556e1d0974cdd13e8224f 
>   src/master/master.cpp be0db42da3c59761aa154439653d715556465256 
> 
> Diff: https://reviews.apache.org/r/35118/diff/
> 
> 
> Testing
> -------
> 
> make check.
> 
> 
> Thanks,
> 
> Jiang Yan Xu
> 
>

Reply via email to