> On Sept. 9, 2015, 3:46 p.m., Alexander Rukletsov wrote:
> > src/common/values.cpp, line 184
> > <https://reviews.apache.org/r/38158/diff/5/?file=1065425#file1065425line184>
> >
> >     s/Remove/Removes
> >     s/indexes/indices
> >     
> >     Mind refining a comment a bit? It looks like it evolved during time and 
> > contains artifacts from previous versions : ).

FYI both indexes and indices are correct (see 
http://forum.wordreference.com/threads/index-plural-indexes-vs-indices.321709/).


> On Sept. 9, 2015, 3:46 p.m., Alexander Rukletsov wrote:
> > include/mesos/values.hpp, line 21
> > <https://reviews.apache.org/r/38158/diff/5/?file=1065424#file1065424line21>
> >
> >     ```
> >     #include <algorithm>
> >     #include <set>
> >     ```

Should be cpp, or?


> On Sept. 9, 2015, 3:46 p.m., Alexander Rukletsov wrote:
> > src/common/values.cpp, line 198
> > <https://reviews.apache.org/r/38158/diff/5/?file=1065425#file1065425line198>
> >
> >     `nextRemove` cannot be greater than `nextElement`, because you do 
> > `deleteSet.insert(nextElement);` at the end. The only exception is the 
> > first iteration. How about initializing `nextElement = *deleteSet.begin() + 
> > 1` and remove this line?

We also have to erease the first element in deleteSet later, but ok.


> On Sept. 9, 2015, 3:46 p.m., Alexander Rukletsov wrote:
> > src/common/values.cpp, lines 250-271
> > <https://reviews.apache.org/r/38158/diff/5/?file=1065425#file1065425line250>
> >
> >     I think we can conflate this two cases, how about this:
> >     ```
> >     if (range->end() + 1 >= current.begin()) {
> >       range->set_end(std::max(range.end(), current.end()));
> >       deleteSet.insert(y);
> >       ++i;
> >     } else {
> >       break;
> >     }
> >     ```

Yes we could do this. I personally find the 2 distinct cases (especially with 
the range comments) more readable.


- Joerg


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/38158/#review98200
-----------------------------------------------------------


On Sept. 8, 2015, 7:25 p.m., Joerg Schad wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/38158/
> -----------------------------------------------------------
> 
> (Updated Sept. 8, 2015, 7:25 p.m.)
> 
> 
> Review request for mesos, Bernd Mathiske and Till Toenshoff.
> 
> 
> Bugs: MESOS-3051
>     https://issues.apache.org/jira/browse/MESOS-3051
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> The goal of this refactoring was to reuse the Ranges objects as much as 
> possible, as prior there was substantial time spend in allocation/destruction 
> (MESOS-3051).
> 
> 
> Diffs
> -----
> 
>   include/mesos/values.hpp e300580431f7fd6cff06e9617c0227b51c4cb8e2 
>   src/common/values.cpp 750264e603b4cde2011f07f4434a4b34fe3e512f 
>   src/tests/resources_tests.cpp 2ae93a9c8235e5e4643539d409df51c39c6d7e56 
>   src/tests/values_tests.cpp fc35d97894a2de6207b9337180e2160e6f2cb1f5 
> 
> Diff: https://reviews.apache.org/r/38158/diff/
> 
> 
> Testing
> -------
> 
> make check
> 
> 
> Thanks,
> 
> Joerg Schad
> 
>

Reply via email to