> On Sept. 21, 2015, 5:32 p.m., Paul Brett wrote:
> > The PerfTests ROOT_Events and ROOT_Sample both require a supported version 
> > of perf to be installed, however the Parse test does not.  Could we use the 
> > supported() test to disable all events matching both ROOT and Perf?

I am not ideas. Just see a lot of failures in CentOS 6.6. Should we create a 
new filter, which name is "PERF_TEST_"? Also, there are not only 
"PerfTest.ROOT_Events" depends on "supported". I forgot 7~8 test cases is 
failed because of perf events, most of our cgroup test seems need perf_event.


- haosdent


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/38528/#review99773
-----------------------------------------------------------


On Sept. 21, 2015, 5:47 p.m., haosdent huang wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/38528/
> -----------------------------------------------------------
> 
> (Updated Sept. 21, 2015, 5:47 p.m.)
> 
> 
> Review request for mesos, Joris Van Remoortere, Michael Park, and Paul Brett.
> 
> 
> Bugs: MESOS-3471
>     https://issues.apache.org/jira/browse/MESOS-3471
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Disable perf test when perf version is not support.
> 
> 
> Diffs
> -----
> 
>   src/tests/environment.cpp e40cde23daba25b0b61b567ee73682c67e7acbdc 
> 
> Diff: https://reviews.apache.org/r/38528/diff/
> 
> 
> Testing
> -------
> 
> # On CentOS 6.6
> sudo make -j8 check
> 
> 
> Thanks,
> 
> haosdent huang
> 
>

Reply via email to