> On Sept. 23, 2015, 3:14 p.m., Timothy Chen wrote:
> > src/slave/containerizer/mesos/containerizer.cpp, line 767
> > <https://reviews.apache.org/r/38693/diff/1/?file=1083526#file1083526line767>
> >
> >     I think we should consolidate it, but we need to allow it to be passed 
> > in I think as I don't think the logic will be the same for both.
> 
> Jie Yu wrote:
>     Can you elaborate? What do you mean by "allow it to be passed in"?

Tim, 

If it is added as a paraemter of `executorEnvironment()`, can 
DockerContainerizer take advantage of it?

```
map<string, string> executorEnvironment(
    const ExecutorInfo& executorInfo,
    const string& hostDirectory,
    const string& containerDirectory,
    const SlaveID& slaveId,
    const PID<Slave>& slavePid,
    bool checkpoint,
    const Flags& flags,
    bool includeOsEnvironment)
``` 

If names such as MESOS_DIRECTORY and MESOS_SANDBOX have to be used for 
backwards compatibility reason, I think inside the code we can name things 
better to make it easier to differentiate the two (there may be better names 
than `hostDirectory` and `containerDirectory` and I am just suggesting them).

It totally could be a TODO but it would be nice to see them being consolidated.


- Jiang Yan


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/38693/#review100301
-----------------------------------------------------------


On Sept. 23, 2015, 2:51 p.m., Jie Yu wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/38693/
> -----------------------------------------------------------
> 
> (Updated Sept. 23, 2015, 2:51 p.m.)
> 
> 
> Review request for mesos, Timothy Chen, Vinod Kone, and Jiang Yan Xu.
> 
> 
> Bugs: MESOS-3504
>     https://issues.apache.org/jira/browse/MESOS-3504
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Added MESOS_SANDBOX environment variable in Mesos containerizer.
> 
> 
> Diffs
> -----
> 
>   src/slave/containerizer/mesos/containerizer.cpp 
> b4a77e734706f40dc1d2110939d4f33fcbd1fd8c 
>   src/slave/containerizer/mesos/launch.cpp 
> be600e32115d2f30446f68fb80849c6eaf77afc4 
>   src/tests/containerizer/filesystem_isolator_tests.cpp 
> 1478531d3036ed567f14cba58fb3f67fa0b60552 
> 
> Diff: https://reviews.apache.org/r/38693/diff/
> 
> 
> Testing
> -------
> 
> sudo make check
> 
> 
> Thanks,
> 
> Jie Yu
> 
>

Reply via email to