-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/39014/#review101681
-----------------------------------------------------------


I would have liked to ship this but it looks like the fsLayers rename related 
changes need adjustement. Can you please pull that out into a separate patch 
please?

Let's have this patch focus only on the renaming of ManifestResponse.


src/slave/containerizer/provisioner/docker/registry_client.hpp (line 67)
<https://reviews.apache.org/r/39014/#comment159141>

    Please let's avoid conflating independent changes in these patches, as it 
makes it much easier to go through review when we're doing one thing at a time.
    
    We should pull out naming cleanup into a seperate patch, it looks like 
there is a lot of naming cleanup we need to do on these files outside of just 
fsLayers. Also, how about s/fsLayers/layers/?



src/tests/containerizer/provisioner_docker_tests.cpp (line 67)
<https://reviews.apache.org/r/39014/#comment159137>

    Can you do a sweep to remove all of the namespace aliases? If you want to 
pull them out of the RegistryClient let's use another patch.



src/tests/containerizer/provisioner_docker_tests.cpp (line 429)
<https://reviews.apache.org/r/39014/#comment159138>

    In general please try to use succict, non-redundant names:
    
    s/manifestResponseFuture/manifest
    
    It's clear here that this is a future from the type and now that we've 
removed response from the type we should remove it from the name as well.


- Ben Mahler


On Oct. 5, 2015, 8:57 p.m., Jojy Varghese wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/39014/
> -----------------------------------------------------------
> 
> (Updated Oct. 5, 2015, 8:57 p.m.)
> 
> 
> Review request for mesos and Ben Mahler.
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> RegistryClient refactor: renamed ManifestResponse as per review comments.
> 
> 
> Diffs
> -----
> 
>   src/slave/containerizer/provisioner/docker/registry_client.hpp 
> 9d5d15455192e2d75fe5cd7fa8755fb8cc67e185 
>   src/slave/containerizer/provisioner/docker/registry_client.cpp 
> c2040b48ea43fdb29766994c244273d3fa9ee3cd 
>   src/tests/containerizer/provisioner_docker_tests.cpp 
> d895eb9d0723e52cff8b21ef2deeaef1911d019c 
> 
> Diff: https://reviews.apache.org/r/39014/diff/
> 
> 
> Testing
> -------
> 
> make check.
> 
> 
> Thanks,
> 
> Jojy Varghese
> 
>

Reply via email to