> On Nov. 25, 2015, 5:01 a.m., Michael Park wrote:
> > src/tests/persistent_volume_endpoints_tests.cpp, lines 159-162
> > <https://reviews.apache.org/r/40247/diff/6/?file=1137474#file1137474line159>
> >
> >     I would suggest that we reorder these since we expect `registered` to 
> > occur before `resourceOffers`. Although functionally, it should have no 
> > difference.
> >     
> >     Occurences below as well.

Sounds good. Actually I just copied this code from 
reservation_endpoints_test.cpp :) So I'll fix similar code there, in a separate 
review.


> On Nov. 25, 2015, 5:01 a.m., Michael Park wrote:
> > src/master/http.cpp, line 541
> > <https://reviews.apache.org/r/40247/diff/6/?file=1137470#file1137470line541>
> >
> >     I feel like this could be taken as "remove/filter the disk resources" 
> > rather than "remove the DiskInfo portion of each resource" :(
> >     
> >     I thought maybe `removeVolumes` but I think that has the same issue as 
> > before. I also think we should keep in mind that we may introduce an alias 
> > for, and deprecate `flatten`.
> >     
> >     Another one would be `removeDiskInfos` to be more indicative that the 
> > `DiskInfo` portion of the `Resource`s are being removed, but then the alias 
> > for `flatten` would end up as something like, 
> > `removeRolesAndReservationInfos`...
> >     
> >     This brings me to maybe declaring the state in which this resource is 
> > being transformed into. Something like... `makeRegularDisk` and 
> > `makeUnreserved`?
> >     
> >     What do you think?

I vote for `removeDiskInfos()`, since it is an improvement. If/when we want to 
rename `flatten()` we can always revisit this -- since `removeDiskInfos` is 
private anyway, it should be easy to rename.


> On Nov. 25, 2015, 5:01 a.m., Michael Park wrote:
> > docs/persistent-volume.md, line 248
> > <https://reviews.apache.org/r/40247/diff/6/?file=1137467#file1137467line248>
> >
> >     It looks pretty clear that we allow the creation and destruction of 
> > multiple volumes via these endpoints. Should we call them `create-volumes` 
> > and `destroy-volumes` respectively?

Yeah, I suppose that is better. I guess it a bit weird that you can't create 
multiple volumes in the general case (i.e., you can only create n volumes on a 
single agent, not n volumes in general), but I suppose that is okay.


- Neil


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/40247/#review107913
-----------------------------------------------------------


On Nov. 23, 2015, 5:06 p.m., Neil Conway wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/40247/
> -----------------------------------------------------------
> 
> (Updated Nov. 23, 2015, 5:06 p.m.)
> 
> 
> Review request for mesos, Greg Mann and Michael Park.
> 
> 
> Bugs: MESOS-2455
>     https://issues.apache.org/jira/browse/MESOS-2455
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Added HTTP endpoints for creating and destroying persistent volumes.
> 
> 
> Diffs
> -----
> 
>   docs/persistent-volume.md 0951ccb69daaa19b959e11cf3bf972a674a58305 
>   docs/reservation.md 81f21c3755b216b0932876c1ddd9de4d3fbe814a 
>   src/Makefile.am 8d14ff803249b5b81b696d40d37e013960dee41b 
>   src/master/http.cpp 1c4f1406f5d917f5d655a7d61d311365f8999ce0 
>   src/master/master.hpp d4b1edde98925fd51e056f253758afea779be9ed 
>   src/master/master.cpp d2bc83cd77ae7fe723ccb35a7c1e0b70a04a0d6e 
>   src/tests/mesos.hpp b3f69ccb9870b17a335a2fe7dbf2802c1b709e6b 
>   src/tests/persistent_volume_endpoints_tests.cpp PRE-CREATION 
> 
> Diff: https://reviews.apache.org/r/40247/diff/
> 
> 
> Testing
> -------
> 
> (1) make check, including newly added tests
> 
> (2) Manually created/removed persistent volumes via HTTP endpoints + curl.
> 
> (3) Previewed docs in Github gist.
> 
> 
> Thanks,
> 
> Neil Conway
> 
>

Reply via email to