> On Feb. 3, 2016, 11:41 p.m., Vinod Kone wrote:
> > src/tests/scheduler_tests.cpp, line 201
> > <https://reviews.apache.org/r/41291/diff/5/?file=1194021#file1194021line201>
> >
> >     s/execCallbacks/executorCallbacks/

Renamed this to `executor` now as per our discussion.


> On Feb. 3, 2016, 11:41 p.m., Vinod Kone wrote:
> > src/tests/scheduler_tests.cpp, lines 303-305
> > <https://reviews.apache.org/r/41291/diff/5/?file=1194021#file1194021line303>
> >
> >     It would be gret if we can send a TASK_RUNNING update right from here, 
> > like we did with the driver based executor to minimize the boiler plate 
> > code needed for every test.
> >     
> >     This likely means that the ExecutorCallbacks class needs access to a 
> > pointer of TestMesos class.

Added the ability to pass the pointer to `TestMesos`. Cleaned up things a lot. 
Thanks for the suggestion.


> On Feb. 3, 2016, 11:41 p.m., Vinod Kone wrote:
> > src/tests/scheduler_tests.cpp, line 308
> > <https://reviews.apache.org/r/41291/diff/5/?file=1194021#file1194021line308>
> >
> >     s/exec/executor/

We no longer get access to `TestMesos` now. Hence, the issue is no longer 
valid. Dropping.


- Anand


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/41291/#review117703
-----------------------------------------------------------


On Feb. 4, 2016, 11:12 p.m., Anand Mazumdar wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/41291/
> -----------------------------------------------------------
> 
> (Updated Feb. 4, 2016, 11:12 p.m.)
> 
> 
> Review request for mesos, Ben Mahler and Vinod Kone.
> 
> 
> Bugs: MESOS-4457
>     https://issues.apache.org/jira/browse/MESOS-4457
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> This change modifies the existing scheduler tests to use the new executor 
> HTTP library instead of the old driver based interface.
> 
> 
> Diffs
> -----
> 
>   src/tests/scheduler_tests.cpp 4e2db2ac40c59b9b9a97cd214b3cd1e727a4f0ad 
> 
> Diff: https://reviews.apache.org/r/41291/diff/
> 
> 
> Testing
> -------
> 
> make check
> 
> 
> Thanks,
> 
> Anand Mazumdar
> 
>

Reply via email to