-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/46813/#review131075
-----------------------------------------------------------


Ship it!




Having applied this patch to the master branch, I ran builds and tests for 
CentOS 6, CentOS7, Debian 8, Fedora 23, Ubuntu 12/14/15. (With and without SLL 
enabled.) In each case, building with setuptools instead of distribute worked 
equally well. I also tried Ubuntu 16. In this case building works with 
setuptools, but not with distribute. I'd say let's move on and switch to 
setuptools now.

- Bernd Mathiske


On April 29, 2016, 2:13 a.m., Zhiwei Chen wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/46813/
> -----------------------------------------------------------
> 
> (Updated April 29, 2016, 2:13 a.m.)
> 
> 
> Review request for mesos, Adam B, haosdent huang, Kapil Arya, and Joseph Wu.
> 
> 
> Bugs: MESOS-5244
>     https://issues.apache.org/jira/browse/MESOS-5244
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Update distribute to setuptools.
> 
> 
> Diffs
> -----
> 
>   3rdparty/Makefile.am 0523151d924a1398334767bd401ae84e41bdceb7 
>   3rdparty/distribute-0.6.26.tar.gz 3a598ccd4bfdfdf250a6d7a28552677394f14a76 
>   3rdparty/setuptools-20.9.0.tar.gz PRE-CREATION 
>   3rdparty/versions.am a94723e213dbbbd1df7e1b784386023412f7b961 
>   LICENSE 19130d977986dc9e23872817251ffcaa5a3c2c7d 
>   configure.ac ae91a07e2bafd97566ac6e6873990302acad14c9 
>   mpi/mpiexec-mesos.in 021dd5b6b9c1c601b81d5bf49fda1bd23c2040ee 
>   src/Makefile.am 53de98f43629dc94f7619324369caf88407b2f41 
>   src/examples/python/test-containerizer.in 
> b8258e75a3cd5f8d18ab8eff8196c5374db4f629 
>   src/examples/python/test-executor.in 
> 6be0ad2d339ff43d074e9688978af1ddf956803c 
>   src/examples/python/test-framework.in 
> 59bab82962c5846c6be288f3d392986e146e9da6 
>   support/coverage.sh 7edfec27d29fa900d35894c7778fcb7cfde513b8 
> 
> Diff: https://reviews.apache.org/r/46813/diff/
> 
> 
> Testing
> -------
> 
> make && make install on Ubuntu 14.04/16.04, RHEL 6.6/7.1 and OS X 10.10.5.
> 
> NOTE: I tested on my RHEL 6.6 and failed, because the package 
> pytz-2010h-2.el6.noarch was installed, when I removed this package verything 
> ok. The default RHEL/CentOS 6.6 has no pytz-2010h-2.el6.noarch, so I think 
> it's ok for this patch.
> 
> 
> Thanks,
> 
> Zhiwei Chen
> 
>

Reply via email to