-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/46923/#review132571
-----------------------------------------------------------




src/master/master.hpp (line 929)
<https://reviews.apache.org/r/46923/#comment196804>

    why does this need to be a member function? can it just be a static helper 
function inside master.cpp?



src/master/master.cpp (line 1386)
<https://reviews.apache.org/r/46923/#comment196803>

    s/we/We/
    
    All comments should start with a capital letter and end with a period.



src/master/master.cpp (lines 7334 - 7336)
<https://reviews.apache.org/r/46923/#comment196807>

    can this just be
    
    ```
    return Duration::Create(frameworknfo.failover_timeout()).isSome()?
    ```
    
    at this point, do we even need to extract this out into a function at all?



src/tests/master_tests.cpp (line 4473)
<https://reviews.apache.org/r/46923/#comment196806>

    2 blank lines between outer elements.


- Vinod Kone


On May 6, 2016, 12:09 p.m., Jose Guilherme Vanz wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/46923/
> -----------------------------------------------------------
> 
> (Updated May 6, 2016, 12:09 p.m.)
> 
> 
> Review request for mesos, Guangya Liu, Kevin Sweeney, Neil Conway, and Vinod 
> Kone.
> 
> 
> Bugs: MESOS-1575
>     https://issues.apache.org/jira/browse/MESOS-1575
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Frameworks were allowed to subscribe themselves with invalid failover
> timeout. For this reason, a validation has been made in the master to
> deny framework subscription if it set a invalid value for the failover
> timeout. MESOS-1575
> 
> 
> Diffs
> -----
> 
>   src/master/master.hpp 3e55114ee7866e06513071e86e15608099dae052 
>   src/master/master.cpp 6d3e0f7c634690a35eec1ce827b705e04c3af87e 
>   src/tests/master_tests.cpp 8e00753fcbcd0cae1d08aad387b08aa17c7f63ad 
> 
> Diff: https://reviews.apache.org/r/46923/diff/
> 
> 
> Testing
> -------
> 
> 
> Thanks,
> 
> Jose Guilherme Vanz
> 
>

Reply via email to