> On Oct. 14, 2016, 8:25 p.m., Jiang Yan Xu wrote:
> > This is conversation carried over from /r/52556/
> > 
> > Now that we're in the business of (re)naming things for consistency, 
> > understandability and unambiguity, how about we just follow some widely 
> > used conventions:
> > https://www.gnu.org/prep/standards/html_node/Directory-Variables.html
> > 
> > The motivation in the renaming in /r/52556/ seems to be because the number 
> > of binaries in the directory has grown and not all related to the launcher 
> > anymore. `--libexec_dir` or `MESOS_LIBEXEC_DIR` feels pretty clear for what 
> > it is.
> > 
> > BTW, when I first see the flag `--runtime_dir` on the agent, I thought it 
> > was for the "runtime binaries" as well. Would `--runstate_dir` or 
> > `MESOS_RUNSTATE_DIR` (from the linked doc) be better names? 
> > 
> > ^^ @Jie

The goal of this patch is to resolve MESOS-6288 (The default executor should 
maintain launcher_dir) and therefore to unblock MESOS-6119 (TCP health checks 
are not portable).

I agree that `launcher_dir` is not a good name for the flag and volunteer for 
doing patch with a sweeping rename ss part of MESOS-6341 (Improve environment 
variable setting for executors, tasks and nested containers).


- Gastón


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/52880/#review152730
-----------------------------------------------------------


On Oct. 14, 2016, 5:18 p.m., Gastón Kleiman wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/52880/
> -----------------------------------------------------------
> 
> (Updated Oct. 14, 2016, 5:18 p.m.)
> 
> 
> Review request for mesos, Alexander Rukletsov, Anand Mazumdar, haosdent 
> huang, Jie Yu, and Jiang Yan Xu.
> 
> 
> Bugs: MESOS-6288
>     https://issues.apache.org/jira/browse/MESOS-6288
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Added "launcher_dir" to the default executor flags.
> 
> 
> Diffs
> -----
> 
>   src/launcher/default_executor.cpp af4a97f7de5f2157aa65fdab742455b0683c40a4 
>   src/slave/slave.cpp 6bd9b49c3bbdb973a0d03552ae8fe55b33371083 
> 
> Diff: https://reviews.apache.org/r/52880/diff/
> 
> 
> Testing
> -------
> 
> `make check`
> 
> 
> Thanks,
> 
> Gastón Kleiman
> 
>

Reply via email to