> On Feb. 3, 2017, 1:34 p.m., Alexander Rukletsov wrote:
> > src/tests/health_check_tests.cpp, lines 2118-2119
> > <https://reviews.apache.org/r/55901/diff/3/?file=1622284#file1622284line2118>
> >
> >     Why do we need to expilictly create `containerizer`?

Because the implicit `containerizer` is started in local mode. 
`LaunchNestedContainerSession` (used by cmd health checks) tries to start a IO 
switchboard, which doesn't work in local mode yet.


> On Feb. 3, 2017, 1:34 p.m., Alexander Rukletsov wrote:
> > src/checks/health_checker.hpp, line 207
> > <https://reviews.apache.org/r/55901/diff/3/?file=1622281#file1622281line207>
> >
> >     How about calling it `commandCheckViaAgent`?

Good idea, done.


> On Feb. 3, 2017, 1:34 p.m., Alexander Rukletsov wrote:
> > src/checks/health_checker.cpp, line 130
> > <https://reviews.apache.org/r/55901/diff/3/?file=1622282#file1622282line130>
> >
> >     s/createRequest/createV1AgentAPIRequest?
> >     remove `inline`
> >     
> >     This looks like a utility function not really related to the health 
> > checker library. Maybe put it into "src/slave/api_utils.{hpp|cpp}"?

I renamed the function. Vinod suggested to make it `inline` what's wrong with 
that?

This function as-is is specific to how we perform requests in this file 
(`keep_alive = false`, protobuf serialization). Since it is used only in two 
places, I'm tempted to removed it and put the code inline in the corresponding 
methods.


> On Feb. 3, 2017, 1:34 p.m., Alexander Rukletsov wrote:
> > src/tests/health_check_tests.cpp, line 2107
> > <https://reviews.apache.org/r/55901/diff/3/?file=1622284#file1622284line2107>
> >
> >     Why not spelling out `cmd`?

Renamed.


> On Feb. 3, 2017, 1:34 p.m., Alexander Rukletsov wrote:
> > src/tests/health_check_tests.cpp, lines 2154-2155
> > <https://reviews.apache.org/r/55901/diff/3/?file=1622284#file1622284line2154>
> >
> >     Formatting.
> >     
> >     Also it is probably a good idea to explicitly say you don't care about 
> > further updates.

Fixed the formatting. We don't have such a comment in most of the other tests 
in this file.


- Gastón


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/55901/#review164117
-----------------------------------------------------------


On Feb. 3, 2017, 5:15 p.m., Gastón Kleiman wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/55901/
> -----------------------------------------------------------
> 
> (Updated Feb. 3, 2017, 5:15 p.m.)
> 
> 
> Review request for mesos, Alexander Rukletsov, Anand Mazumdar, haosdent 
> huang, and Vinod Kone.
> 
> 
> Bugs: MESOS-6280
>     https://issues.apache.org/jira/browse/MESOS-6280
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Added support for command health checks to the default executor.
> 
> 
> Diffs
> -----
> 
>   src/checks/health_checker.hpp 95da1ff7dd6b222a93076633eb3757ec9aa43cf6 
>   src/checks/health_checker.cpp 58380dc18896f659aa9c4fb4bb567a55bba97f6b 
>   src/launcher/default_executor.cpp 97eee05cac8cb1f62d43e2aecc08a8e54e49eac3 
>   src/tests/health_check_tests.cpp 8418cd91484fd26734de16255b37f3ebf574f5eb 
> 
> Diff: https://reviews.apache.org/r/55901/diff/
> 
> 
> Testing
> -------
> 
> Introduced a new test: `HealthCheckTest.DefaultExecutorCmdHealthCheck`. It 
> passes on Linux, but not on macOS.
> 
> 
> Thanks,
> 
> Gastón Kleiman
> 
>

Reply via email to