-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/61575/#review182895
-----------------------------------------------------------




src/tests/default_executor_tests.cpp
Lines 537 (patched)
<https://reviews.apache.org/r/61575/#comment258837>

    s/terimate/terminate/



src/tests/default_executor_tests.cpp
Lines 593-597 (patched)
<https://reviews.apache.org/r/61575/#comment258839>

    In some tests we do this instead:
    
    ```
      v1::ExecutorInfo executorInfo = v1::createExecutorInfo(
          v1::DEFAULT_EXECUTOR_ID.value(),
          None(),
          None(),
          v1::ExecutorInfo::DEFAULT);
    ```
    
    At some point we might want to choose one approach and do a sweeping change 
in this file.



src/tests/default_executor_tests.cpp
Lines 600 (patched)
<https://reviews.apache.org/r/61575/#comment258840>

    s/EXPECT_NE(0, 
offers->offers().size());/EXPECT_FALSE(offers->offers().empty)());



src/tests/default_executor_tests.cpp
Lines 613-661 (patched)
<https://reviews.apache.org/r/61575/#comment258842>

    What do you think about the following shorter (and IMHO more readable) 
approach?
    
    ```
      v1::Offer::Operation launchGroup = v1::LAUNCH_GROUP(
          executorInfo,
          v1::createTaskGroupInfo({taskInfo}));
    
      Future<v1::scheduler::Event::Update> update1;
      EXPECT_CALL(*scheduler, update(_, _))
        .WillOnce(DoAll(
            FutureArg<1>(&update1),
            v1::scheduler::SendAcknowledge(
                frameworkId,
                offer.agent_id())));
    
      mesos.send(v1::createCallAccept(
          frameworkId,
          offer,
          {reserve, create, launchGroup}));
    ```


- Gastón Kleiman


On Aug. 14, 2017, 5:59 p.m., Anand Mazumdar wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/61575/
> -----------------------------------------------------------
> 
> (Updated Aug. 14, 2017, 5:59 p.m.)
> 
> 
> Review request for mesos, Jie Yu and Vinod Kone.
> 
> 
> Bugs: MESOS-7879
>     https://issues.apache.org/jira/browse/MESOS-7879
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> This test uses the kill policy helper and blocks the SIGTERM signal.
> 
> 
> Diffs
> -----
> 
>   src/tests/default_executor_tests.cpp 
> b9776314a8781963b92ba9ac297654f61a443bc8 
> 
> 
> Diff: https://reviews.apache.org/r/61575/diff/2/
> 
> 
> Testing
> -------
> 
> make check
> 
> 
> Thanks,
> 
> Anand Mazumdar
> 
>

Reply via email to