-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/65994/#review199339
-----------------------------------------------------------


Fix it, then Ship it!





src/master/master.cpp
Lines 8212-8214 (original), 8206-8208 (patched)
<https://reviews.apache.org/r/65994/#comment279648>

    Nit: I wonder if we should move this above the `if 
(operation->info().has_id() && frameworkId.isSome())` clause, to improve 
readability slightly?
    
    We have two mutually exclusive cases: either we forward the update to the 
framework, or we ACK it ourselves (or neither).
    
    So, maybe it's a bit more readable if we do:
    1) Update the operation internally
    2) If has ID, forward
    3) If doesn't have ID, ACK
    
    WDYT?


- Greg Mann


On March 16, 2018, 7:57 p.m., Gaston Kleiman wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/65994/
> -----------------------------------------------------------
> 
> (Updated March 16, 2018, 7:57 p.m.)
> 
> 
> Review request for mesos, Greg Mann and Zhitao Li.
> 
> 
> Bugs: MESOS-8189
>     https://issues.apache.org/jira/browse/MESOS-8189
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Made the master forward operation status updates to the schedulers.
> 
> 
> Diffs
> -----
> 
>   src/master/master.cpp 223ebf29ac4dd1dea9080e4bef4b2d4d064d847f 
> 
> 
> Diff: https://reviews.apache.org/r/65994/diff/3/
> 
> 
> Testing
> -------
> 
> `sudo bin/mesos-tests.sh` on GNU/Linux
> 
> 
> Thanks,
> 
> Gaston Kleiman
> 
>

Reply via email to