-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/66120/#review199602
-----------------------------------------------------------




src/tests/mesos.hpp
Lines 203-207 (original), 203-207 (patched)
<https://reviews.apache.org/r/66120/#comment279925>

    Could you just add the `mock` parameter to this overload instead of adding 
a new one?



src/tests/slave_tests.cpp
Line 4747 (original), 4747-4748 (patched)
<https://reviews.apache.org/r/66120/#comment279927>

    Nit: newline here?



src/tests/slave_tests.cpp
Line 4813 (original), 4816 (patched)
<https://reviews.apache.org/r/66120/#comment279942>

    Let's be more specific with this comment. Perhaps:
    
    "The `unschedule()` function is used to prevent premature garbage 
collection when the framework directory already exists due to a 
previously-launched task. Simulate this scenario by creating the executor 
directory manually."



src/tests/slave_tests.cpp
Line 4825 (original), 4826 (patched)
<https://reviews.apache.org/r/66120/#comment279931>

    s/unscheudle/unschedule/


- Greg Mann


On March 16, 2018, 6:17 p.m., Meng Zhu wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/66120/
> -----------------------------------------------------------
> 
> (Updated March 16, 2018, 6:17 p.m.)
> 
> 
> Review request for mesos and Greg Mann.
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> The test `RemoveExecutorUponFailedTaskGroupLaunch`
> currently depends on catching and modifying the input
> arguments of agent `__run()` function to mock the
> garbage collector behavior. Using mock garbage collector
> gives better readability and more functionality.
> 
> 
> Diffs
> -----
> 
>   src/tests/mesos.hpp 2c3d0c9350bbbbcd2223ff20c0797d1849d38c19 
>   src/tests/mesos.cpp d82963195573dd9ed7d12a7708f64a236b28cdf1 
>   src/tests/slave_tests.cpp f76500ebdb67f131a57a3b5aaae8c952d019e354 
> 
> 
> Diff: https://reviews.apache.org/r/66120/diff/2/
> 
> 
> Testing
> -------
> 
> make check
> 
> 
> Thanks,
> 
> Meng Zhu
> 
>

Reply via email to