Github user tgravescs commented on a diff in the pull request:
    --- Diff: core/src/main/scala/org/apache/spark/util/Utils.scala ---
    @@ -2420,6 +2420,44 @@ private[spark] object Utils extends Logging {
    +private[spark] class CallerContext(
    +   appName: Option[String] = None,
    +   appID: Option[String] = None,
    +   appAttemptID: Option[String] = None,
    +   jobID: Option[Int] = None,
    +   stageID: Option[Int] = None,
    +   stageAttemptId: Option[Int] = None,
    +   taskId: Option[Long] = None,
    +   taskAttemptNumber: Option[Int] = None) extends Logging {
    +   val AppName = if (appName.isDefined) s"_AppName_${appName.get}" else ""
    --- End diff --
    thinking about this a little more I think we should just remove app name 
altogether. For tracking purposes the app id should be enough. The app name 
adds in a bunch of unknowns (length or it, weird characters or just spaces) 
which could cause things in the audit log to be less useful.

If your project is set up for it, you can reply to this email and have your
reply appear on GitHub as well. If your project does not have this feature
enabled and wishes so, or if the feature is enabled but not working, please
contact infrastructure at or file a JIRA ticket
with INFRA.

To unsubscribe, e-mail:
For additional commands, e-mail:

Reply via email to