FrankYang0529 commented on PR #637: URL: https://github.com/apache/yunikorn-k8shim/pull/637#issuecomment-1641893258
> Seeing quite a few test failures on this, need to investigate and fix. The root cause of error test cases is that we can't add child queue to a draining queue. In the first case, we add three queues `root.fence`, `root.fence.child1`, and `root.fence.child2`. After we reset the configuration, these three queues will get into the draining state. Then, another case tries to add child queues to `root.fence` and the case gets error. Currently, the yunikorn-core will clean draining queues every 10 seconds. The duration is hardcoded in the source code. Users can't update it. Do we want to add the setting to the configuration? If yes, I can help to add it. CI failed job: https://github.com/apache/yunikorn-k8shim/actions/runs/5575867672/jobs/10202470269 Cleaning draining queues source code: https://github.com/apache/yunikorn-core/blob/129c0de6b12b21b4282631b2c0b6df188ce7ae80/pkg/scheduler/partition_manager.go#L70-L87 -- This is an automated message from the Apache Git Service. To respond to the message, please log on to GitHub and use the URL above to go to the specific comment. To unsubscribe, e-mail: [email protected] For queries about this service, please contact Infrastructure at: [email protected]
