Rename onsubmit on a4j:queue and a4j:attachQueue to onbegin
-----------------------------------------------------------

                 Key: RF-11709
                 URL: https://issues.jboss.org/browse/RF-11709
             Project: RichFaces
          Issue Type: Task
      Security Level: Public (Everyone can see)
          Components: component-a4j-core
    Affects Versions: 4.0.0.Final
            Reporter: Lukáš Fryč


In component reference, there is no {{onsubmit}} documented, but there is 
{{onbegin}} with semantically same behavior.

In order to unify naming with all other components, I suggest to rename it.
We should inspect also other components for this attribute and do the same.

It is possible to make {{onsubmit}} alternative so it won't break backward 
compatibility and make it hidden.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: 
https://issues.jboss.org/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

_______________________________________________
richfaces-issues mailing list
[email protected]
https://lists.jboss.org/mailman/listinfo/richfaces-issues

Reply via email to