See https://bugzilla.redhat.com/show_bug.cgi?id=1853597#c11

pkg_resources from setuptools 42+ no longer only use platform.python_version(),
but also platform.python_version_tuple() -- this was updated in packaging 19.1+.

This fix makes it work again with both new and old setuptools,
hopefully for some while.

https://github.com/pypa/setuptools/commit/bf069fe9ddcadaa2c029067601d06a07d037d4f7
https://github.com/pypa/packaging/commit/86a443f3185024edd0b826afdd91d8f9a4917022
You can view, comment on, or merge this pull request online at:

  https://github.com/rpm-software-management/rpm/pull/1308

-- Commit Summary --

  * pythondistdeps.py: Adapt Python version marker workaround for setuptools 42+

-- File Changes --

    M scripts/pythondistdeps.py (1)

-- Patch Links --

https://github.com/rpm-software-management/rpm/pull/1308.patch
https://github.com/rpm-software-management/rpm/pull/1308.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/rpm-software-management/rpm/pull/1308
_______________________________________________
Rpm-maint mailing list
Rpm-maint@lists.rpm.org
http://lists.rpm.org/mailman/listinfo/rpm-maint

Reply via email to