Thanks Matt,

I'm beginning to believe this isn't possible. I've tried both nontsec and
ntsec with no luck, and I've tried with and without -o -p -g. Still takes
ownership from administrators and gives it to the rsync user.

The only way around this would be to use the rsyncd which runs as root, and
is not possible (security wise) in our enviroment.

I've also tried setting the rsync user to the administrators group with no

Matt McCutchen-3 wrote:
> On 7/24/07, jhurd8025 <[EMAIL PROTECTED]> wrote:
>> Case point: 2 Servers (both with Windows Server 2k3 & cygwin). Running
>> ssh on
>> the destination server.
>> Problem: The rsync user will take ownership over any files copied over
>> from
>> the source server. This takes ownership away from the administrators
>> group,
>> thus disallowing inherited permissions.
>> Is there any way around not taking ownership away from the administrators
>> group and giving it to the rsync user?
> If you are telling rsync to preserve ownership by passing -og or -a,
> try turning ownership preservation off by removing the -og or putting
> --no-o --no-g after the -a.  Also try with the environment variable
> CYGWIN set to ntsec and try with it set to nontsec.  One of these
> combinations is likely to do what you want.
> Matt
> -- 
> To unsubscribe or change options:
> Before posting, read:

View this message in context:
Sent from the Samba - rsync mailing list archive at

To unsubscribe or change options:
Before posting, read:

Reply via email to