Bug ID: 15335
           Summary: Environment variables in remote host's path do not
                    resolve properly
           Product: rsync
           Version: 3.2.0
          Hardware: x86
                OS: Linux
            Status: NEW
          Severity: major
          Priority: P5
         Component: core
        QA Contact:
  Target Milestone: ---

We've had an rsync command that has worked for quite a while (1+ years), but
suddenly started getting errors after we upgraded rsync from version 3.2.3 to
3.2.7.  I'm not sure exactly which minor release broke our expectation of how
environment variables are used in remote host paths, but there certainly seems
to be some major change.  See the example command below in which we were
protecting the remote environment variable with single quotes to ensure it
resolved on the remote host and not locally.  I was able to reliable reproduce
this issue with 3.2.7 and show that the command worked with 3.2.3.

Example Command:

rsync -rl /home/user/test_dir 'user@hostname:$PROJECTS_HOME/INFINITE'

3.2.7 -> rsync: mkdir "/p/home/rlarson/$PROJECTS_HOME/INFINITE" failed: No such
file or directory

3.2.3 -> successful rsync

A few notes:
1. The env var and path does exist on remote system
2. "/p/home/rlarson" is my  $HOME dir on remote system
3. Both source and dest OS are Linux

Anything else I can add to help troubleshoot this issue please let me know.

You are receiving this mail because:
You are the QA Contact for the bug.
Please use reply-all for most replies to avoid omitting the mailing list.
To unsubscribe or change options:
Before posting, read:
  • [Bug 15335] New: Envi... just subscribed for rsync-qa from bugzilla via rsync

Reply via email to