It should be statically linked.
Maybe the dependencies are not completely removed everywhere?

Florian can you check please if the package scripts are using
--enable-kafka-static properly?

The adisconbuild-librdkafka packages are used for building only, and we
need them to get the static builds running on Launchpad!

Best regards,
Andre Lorbach

> -----Original Message-----
> From: rsyslog [mailto:rsyslog-boun...@lists.adiscon.com] On Behalf Of
> Rainer Gerhards
> Sent: Monday, April 16, 2018 8:26 PM
> To: rsyslog-users <rsyslog@lists.adiscon.com>
> Subject: Re: [rsyslog] librdkafka packages in
v8-stable/epel-7/x86_64/RPMS
>
> Mmmhhhh... I was told that we link statically to librdkafka, so there
should
> no kafka package at all be installed (actually this was what I asked
for).
>
> @florian, @andre can you comment?
>
> Rainer
>
> Sent from phone, thus brief.
>
> Derek DiFilippo <de...@jsonar.com> schrieb am Mo., 16. Apr. 2018, 20:19:
>
> > Hi Rainer, hi everyone,
> >
> > In addition to a dependency on rsyslog, one of our packages now
> > depends on librdkafka and librdkafka-devel.
> >
> > We want to use the librdkafka packages provided by epel, nothing
fancy.
> >
> > I'm seeing a conflict between the librdkafka1 package in the rsyslog
> > repo (note the "1" at the end of the library name) and the ones
> > provided by epel.
> >
> > ...
> > ...
> >  librdkafka          x86_64 0.11.3-1.el7   epel
> > 326 k
> >  librdkafka-devel  x86_64 0.11.3-1.el7   epel
> >  43 k
> >  librdkafka1         x86_64 0.8.5-0         rsyslog_v8
> >   100 k
> > ...
> > ...
> >
> > Transaction check error:
> >   file /usr/lib64/librdkafka++.so.1 conflicts between attempted
> > installs of
> > librdkafka1-0.8.5-0.x86_64 and librdkafka-0.11.3-1.el7.x86_64
> >   file /usr/lib64/librdkafka.so.1 conflicts between attempted installs
> > of
> > librdkafka1-0.8.5-0.x86_64 and librdkafka-0.11.3-1.el7.x86_64
> >
> > Can librdkafka1 be removed from the rsyslog repo? What is the
> > rationale for pinning a version of librdkafka via the librdkafka1
package?
> >
> > If librdkafka1 must stay in the rsyslog repo what do you recommend as
> > the best practice for resolving this conflict?
> >
> > I see a lot of "adisconbuild-librdkafka*" packages in the repo. Why
> > are they there? Is the solution to change the dependency in *our*
> > package form librdkafka to adiscon-librdkafka? I might be comfortable
> > with that if I know why the adiscon packages are there.
> >
> > As a fallback we could add librdkafka as an external project via CMake
> > and build from source but I wanted to check in here first before
> proceeding.
> >
> > Apologies if I missed something obvious. I did my best googling
> > due-diligence and couldn't find anyhing satisfactory.
> >
> > Thanks for your time & patience!
> > _______________________________________________
> > rsyslog mailing list
> > http://lists.adiscon.net/mailman/listinfo/rsyslog
> > http://www.rsyslog.com/professional-services/
> > What's up with rsyslog? Follow https://twitter.com/rgerhards NOTE
> > WELL: This is a PUBLIC mailing list, posts are ARCHIVED by a myriad of
> > sites beyond our control. PLEASE UNSUBSCRIBE and DO NOT POST if you
> > DON'T LIKE THAT.
> >
> _______________________________________________
> rsyslog mailing list
> http://lists.adiscon.net/mailman/listinfo/rsyslog
> http://www.rsyslog.com/professional-services/
> What's up with rsyslog? Follow https://twitter.com/rgerhards NOTE WELL:
> This is a PUBLIC mailing list, posts are ARCHIVED by a myriad of sites
beyond
> our control. PLEASE UNSUBSCRIBE and DO NOT POST if you DON'T LIKE THAT.
_______________________________________________
rsyslog mailing list
http://lists.adiscon.net/mailman/listinfo/rsyslog
http://www.rsyslog.com/professional-services/
What's up with rsyslog? Follow https://twitter.com/rgerhards
NOTE WELL: This is a PUBLIC mailing list, posts are ARCHIVED by a myriad of 
sites beyond our control. PLEASE UNSUBSCRIBE and DO NOT POST if you DON'T LIKE 
THAT.

Reply via email to