SOLVED

Ok i found out what was wrong, I had a trailing '/' in $WebBaseURL, and whenever I performed one of those actions the url changed to something like:

http://server.com//rt/

Because of the two forward slashes after the hostname the already stored cookie wasn't being sent. Removing the trailing slash from the $WebBaseURL solved it.

Thank you for your time.

Paulo F. Andrade
[EMAIL PROTECTED]

On Feb 11, 2008, at 6:56 PM, Paulo Filipe Andrade wrote:

Hi,

I'm testing out rt3.6.6 and found that every time I create a ticket,
update a ticket, or take a ticket (possibly even with more actions) I
get sent back to the login page.

In the logs  everything seems fine..

I have set firefox to ask me before storing cookies, and found that
whenever I click one of the mentioned actions I get a new session
cookie. Of course, in the new session I'm not yet authenticated,
therefore I get sent back to the login page.

I'm using postgres, but have also tried setting $WebSessionClass to
'Apache::Session::File', but the problem persists.

I have searched and found many others with this type of problem
(example: 
http://www.gossamer-threads.com/lists/rt/users/58833?search_string=back%20to%20login;#58833)
, but have not found a solution!

Any guidance toward debugging this is welcome!

Paulo F. Andrade
[EMAIL PROTECTED]



_______________________________________________
http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: [EMAIL PROTECTED]


Discover RT's hidden secrets with RT Essentials from O'Reilly Media.
Buy a copy at http://rtbook.bestpractical.com

_______________________________________________
http://lists.bestpractical.com/cgi-bin/mailman/listinfo/rt-users

Community help: http://wiki.bestpractical.com
Commercial support: [EMAIL PROTECTED]


Discover RT's hidden secrets with RT Essentials from O'Reilly Media. 
Buy a copy at http://rtbook.bestpractical.com

Reply via email to