Since the :checked pseudo-class is implemented in $$, you can say
$$('input[name="list[]"]:checked').pluck('value') and save iterating
again with a findAll -- plus it's much more readable :)
Best,
-Nicolas
On Dec 17, 2007 9:52 AM, [EMAIL PROTECTED] <[EMAIL PROTECTED]> wrote:
>
> Try this
> new Ajax.Updater('tpl', url, {
> parameters: {'list[]' : $$
> ('input[name="list[]"]').findAll(function(el) { return
> el.checked }).pluck('value') }
> });
>
> >
>
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "Ruby
on Rails: Spinoffs" group.
To post to this group, send email to [email protected]
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at
http://groups.google.com/group/rubyonrails-spinoffs?hl=en
-~----------~----~----~----~------~----~------~--~---