While working on other designs I'm wondering if a better Class name for Activation is actually Match.
Once a rule is matched and an Activation is produced, as the Activation has fired it remains true. i think I prefer Match.isActive to Activation.isActive Further Activation is harder to shorten and just looks wierd act vs match. Also for evens you have onMatch and onUnMatch which I think is nicer for saying when a rule becomes true and then becomes untry for a given tuple[]. I know as well Clips uses the term PartialMatch instead of the term LeftTuple. Anyway some whimsical thoughts for the day :) Mark _______________________________________________ rules-dev mailing list rules-dev@lists.jboss.org https://lists.jboss.org/mailman/listinfo/rules-dev