Hi Jens,

Le 08/02/2018 à 23:29, Jens Georg a écrit :

There's three things you can check:
1) check that the "default" device, not sysdefault is your hifiberyy


I suppose it's the case : from aplay -L, I have :
"default
sysdefault:CARD=sndrpihifiberry
    snd_rpi_hifiberry_dac,
    Default Audio Device
dmix:CARD=sndrpihifiberry,DEV=0
    snd_rpi_hifiberry_dac,
    Direct sample mixing device
dsnoop:CARD=sndrpihifiberry,DEV=0
    snd_rpi_hifiberry_dac,
    Direct sample snooping device
hw:CARD=sndrpihifiberry,DEV=0
    snd_rpi_hifiberry_dac,
    Direct hardware device without any conversions
plughw:CARD=sndrpihifiberry,DEV=0
    snd_rpi_hifiberry_dac,
    Hardware device with all software conversions"

Indeed, if I use the VLC media player on my Raspberry Pi and chosing "Default" 
in the Audio output options, the music plays.


2) run gst-inspect-1.0 alsasink and check what it outputs as default
value for device and card-name

In trying to do so, I discovered I had both gstreatmer0-1 and gstreamer-1.0 
packages. They are all 1.0 now.
I guess gst-inspect confirms that Hifiberry is indeed the default output :
1) "  name                : The name of the object
                        flags: accès en lecture, accès en écriture
                        String. Default: "alsasink0"
Indeed, "aplay -l" states that my Hifiberry soundcard is card n°0.

2) "  device              : ALSA device, as defined in an asound configuration 
file
                        flags: accès en lecture, accès en écriture
                        String. Default: "default"
  device-name         : Human-readable name of the sound device
                        flags: accès en lecture
                        String. Default: null
  card-name           : Human-readable name of the sound card
                        flags: accès en lecture
                        String. Default: "snd_rpi_hifiberry_dac"

Device-name has a "Default:null" string. Is it normal ?

By the way, when I run gst-inspect, there seems to be a list of mime-types that 
Alsa can read - is it the case ? If so, shouldn't audio/flac be among them ? 
Here there are :
"Pad Templates:
  SINK template: 'sink'
    Availability: Always
    Capabilities:
      audio/x-raw
                 format: { S8, U8, S16LE, S16BE, U16LE, U16BE, S24_32LE, 
S24_32BE, U24_32LE, U24_32BE, S32LE, S32BE, U32LE, U32BE, S24LE, S24BE, U24LE, 
U24BE, S20LE, S20BE, U20LE, U20BE, S18LE, S18BE, U18LE, U18BE, F32LE, F32BE, 
F64LE, F64BE }
                 layout: interleaved
                   rate: [ 1, 2147483647 ]
               channels: [ 1, 2147483647 ]
      audio/x-ac3
                 framed: true
      audio/x-eac3
                 framed: true
      audio/x-dts
                 framed: true
             block-size: { 512, 1024, 2048 }
      audio/mpeg
            mpegversion: 1
        mpegaudioversion: [ 1, 2 ]
                 parsed: true

3) make sure your mixer is actually unmuted

I guess it is, as I can play music using VLC player.
But now that Pulseaudio has been stopped, alsamixer only shows the name of my 
Hifiberry card and says that "this device doesn't have any controls" ("ce 
périphérique n'a pas de commandes") : there is no volume control...
However, it still plays music (Flac, at least. I did not test MP3) directly 
from the Rpi, no problem, without Upnp.
But, once again :
- speaker-test does not produce any sound.
- Nor does Rygel+Playbin controlled from the BubbleUpnp app, whether playing 
MP3 or FLAC...



However, if I now control Rygel with Playbin from the Bubbleupnp app,
there is still no s‎ound, whether FLAC or Mp3 ...
And I noticed that speaker-test won't produce any sound either..which
would mean that the problem lies in my sound configuration, not in
Rygel...
By the way, Rygel's Playbin player ("Voici de la Musique Rpi") seems
to be indicated as Flac-compliant : here is a part of the Bubbleupnp
log‎‎. Thanks !



Yeah, we hard-code that ;)


_______________________________________________
rygel-list mailing list
rygel-list@gnome.org
https://mail.gnome.org/mailman/listinfo/rygel-list

Reply via email to