1. initialization of baseDir isn't correct (aply to all). 2. objects as function parameters should be passed by reference.
3. add documentation about 'addDefinition' function 4. 'cleanFromAlongFuncs' function 5. add 'const' qualifier for constant functions 6. add 'const' qualifier for constant arguments of functions 7. line 159. struct. correct comment. 8. think about classes and objects. (line 170: create FuncDeclaration object before add declaration) 9. 'correctDeclaration' function: add documentation 10. overload input/output streams 11. callgraph.cpp: line 55 12. line 49: params -> currParams 13. line 67: buka is too stupid... 14. line 77: try template algorithms 15. take out logic for possibleDuplication 16. line 146: try to use standard algorithm 17. remove line 158, 179 18. line 192-199 refactor to multiline if-statement 19. 20. line 388: create common function. 21. 395-405: chaeck if this block will be removed 22. magic numbers 23. line 561: use stringstreams 24. line 658: avoid magic numbers 25. PS =============================================== try to use: http://www.cppreference.com/wiki/stl/algorithm/transform =============================================== // try this: class A { int secureVar; public: A( int var ): secureVar(var) {}; void print( A obj ) { std::cout << "secureVar = " << obj.secureVar << std::endl; } }; int main() { A a(5), b(7); a.print(a); a.print(b); return 0; } --~--~---------~--~----~------------~-------~--~----~ You received this message because you are subscribed to the Google Groups "SA_team" group. To post to this group, send email to [email protected] To unsubscribe from this group, send email to [email protected] For more options, visit this group at http://groups.google.ru/group/sa_team?hl=en -~----------~----~----~----~------~----~------~--~---
