Unless someone has a better idea, or objects, maybe the patch should just update the test result in hopf_algebras_with_basis so that the test passes.
> The new method with the less nice name <bound method ... > is much > faster. I asked > here:http://groups.google.com/group/sage-combinat-devel/browse_thread/thre..., > if there is a way to keep the old name, but I didn't get an answer. > > The difference is that the old method was really something generic, > whereas the new method is a faster and non-generic way to get the same > answer... Does anyone know how to do this? I have questions about the function remove_zeros. The function is careful not to delete keys while iterating. Good. This function is only called once in all of sage, namely at the end of dict_linear_combination. Would it be a good idea to inline the code here to save the overhead of the function call? Similar code is inlined in the _from_dict method of CombinatorialFreeModule. There the code is optional depending on a parameter remove_zeros. In some cases _from_dict is called on data that is direct output of dict_linear_combination. This happens in the _neg_ and _sub_ methods of CombinatorialFreeModule. In those cases the zero removal is done twice. I am not I think one could safely pass remove_zeros=False to _from_dict in these two places and maybe other places in the code. But I am not necessarily recommending this. Dan -- You received this message because you are subscribed to the Google Groups "sage-combinat-devel" group. To post to this group, send email to [email protected]. To unsubscribe from this group, send email to [email protected]. For more options, visit this group at http://groups.google.com/group/sage-combinat-devel?hl=en.
