On Thursday, November 27, 2014 at 5:29:35 PM UTC+7, Nathann Cohen wrote:
> > Of course, proposing the statu quo may be unpopular ;-). Another 
> solution I 
> > can propose is to keep f.coefficients() as it is, make f.coeffs() an 
> alias 
> > of the former, and only keep f.list() for the list of all the 
> coefficients. 
> If I understand what you said, you want "coefficients" to be left 
> unchanged for compatibility reasons with other classes, and you want 
> an easy way to get the *list* of coefficients too. While I do not see 
> why this dense/sparse=True argument would be a problem (it is only 
> optional, the default behaviour would not change), what about doing 
> that: 
> 1) Remove .coeffs 
> 2) Update the doc of coefficients to hint that the *list* of 
> coefficients can be obtained through list(P), or P.list ? 
> I thought that we tried in Sage to avoid short names/abbreviations 
> anyway, and it would also avoid the problem raised by Francis: a 
> function whose name abbreviates another's should be an alias, nothing 
> else. 
> Nathann 

How do remove .coeffs ? Help me 

You received this message because you are subscribed to the Google Groups 
"sage-devel" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to sage-devel+unsubscr...@googlegroups.com.
To post to this group, send email to sage-devel@googlegroups.com.
Visit this group at https://groups.google.com/group/sage-devel.
For more options, visit https://groups.google.com/d/optout.

Reply via email to