Author: vlendec
Date: 2006-06-24 09:41:27 +0000 (Sat, 24 Jun 2006)
New Revision: 16490

WebSVN: 
http://websvn.samba.org/cgi-bin/viewcvs.cgi?view=rev&root=samba&rev=16490

Log:
Fix a memleak and two typos
Modified:
   branches/SAMBA_3_0/source/include/rpc_reg.h
   branches/SAMBA_3_0/source/registry/reg_shares.c
   trunk/source/include/rpc_reg.h
   trunk/source/registry/reg_shares.c


Changeset:
Modified: branches/SAMBA_3_0/source/include/rpc_reg.h
===================================================================
--- branches/SAMBA_3_0/source/include/rpc_reg.h 2006-06-23 21:05:45 UTC (rev 
16489)
+++ branches/SAMBA_3_0/source/include/rpc_reg.h 2006-06-24 09:41:27 UTC (rev 
16490)
@@ -91,7 +91,7 @@
  * Registry key types
  *     Most keys are going to be GENERIC -- may need a better name?
  *     HKPD and HKPT are used by reg_perfcount.c
- *             they are special keys that congtain performance data
+ *             they are special keys that contain performance data
  */
 #define REG_KEY_GENERIC                0
 #define REG_KEY_HKPD           1
@@ -99,7 +99,7 @@
 
 /* 
  * container for function pointers to enumeration routines
- * for vitural registry view 
+ * for virtual registry view 
  */ 
  
 typedef struct {

Modified: branches/SAMBA_3_0/source/registry/reg_shares.c
===================================================================
--- branches/SAMBA_3_0/source/registry/reg_shares.c     2006-06-23 21:05:45 UTC 
(rev 16489)
+++ branches/SAMBA_3_0/source/registry/reg_shares.c     2006-06-24 09:41:27 UTC 
(rev 16490)
@@ -124,6 +124,7 @@
                num_values = handle_printing_subpath( path, NULL, val );
 #endif
                
+       SAFE_FREE(path);
        
        return num_values;
 }

Modified: trunk/source/include/rpc_reg.h
===================================================================
--- trunk/source/include/rpc_reg.h      2006-06-23 21:05:45 UTC (rev 16489)
+++ trunk/source/include/rpc_reg.h      2006-06-24 09:41:27 UTC (rev 16490)
@@ -91,7 +91,7 @@
  * Registry key types
  *     Most keys are going to be GENERIC -- may need a better name?
  *     HKPD and HKPT are used by reg_perfcount.c
- *             they are special keys that congtain performance data
+ *             they are special keys that contain performance data
  */
 #define REG_KEY_GENERIC                0
 #define REG_KEY_HKPD           1
@@ -99,7 +99,7 @@
 
 /* 
  * container for function pointers to enumeration routines
- * for vitural registry view 
+ * for virtual registry view 
  */ 
  
 typedef struct {

Modified: trunk/source/registry/reg_shares.c
===================================================================
--- trunk/source/registry/reg_shares.c  2006-06-23 21:05:45 UTC (rev 16489)
+++ trunk/source/registry/reg_shares.c  2006-06-24 09:41:27 UTC (rev 16490)
@@ -124,6 +124,7 @@
                num_values = handle_printing_subpath( path, NULL, val );
 #endif
                
+       SAFE_FREE(path);
        
        return num_values;
 }

Reply via email to