Hi Andrew,

> +const struct dsdb_syntax *find_syntax_map_by_ad_oid(const char *ad_oid) 
> +{
> +     int i;
> +     for (i=0; dsdb_syntaxes[i].ldap_oid; i++) {
> +             if (strcasecmp(ad_oid, dsdb_syntaxes[i].attributeSyntax_oid) == 
> 0) {
> +                     return &dsdb_syntaxes[i];
> +             }
> +     }
> +     return NULL;
> +}
> +
> +const struct dsdb_syntax *find_syntax_map_by_ad_syntax(int oMSyntax) 
> +{
> +     int i;
> +     for (i=0; dsdb_syntaxes[i].ldap_oid; i++) {
> +             if (oMSyntax == dsdb_syntaxes[i].oMSyntax) {
> +                     return &dsdb_syntaxes[i];
> +             }
> +     }
> +     return NULL;
> +}
> +
> +const struct dsdb_syntax *find_syntax_map_by_standard_oid(const char 
> *standard_oid) 
> +{
> +     int i;
> +     for (i=0; dsdb_syntaxes[i].ldap_oid; i++) {
> +             if (strcasecmp(standard_oid, dsdb_syntaxes[i].ldap_oid) == 0) {
> +                     return &dsdb_syntaxes[i];
> +             }
> +     }
> +     return NULL;
> +}

can you please rename this functions to
dsdb_syntax_find_by_*()?

Thanks!

metze

Attachment: signature.asc
Description: OpenPGP digital signature

Reply via email to