On 2014/02/20 03:21, David Sommerseth wrote:
On 19/02/14 15:08, jdow wrote:
On 2014/02/19 01:59, Akemi Yagi wrote:
On Tue, Feb 18, 2014 at 9:29 PM, jdow <j...@earthlink.net> wrote:
What happened to it? It's really hard to get VirtualBox clients to work
OpenGL when you want to use the extra features. They won't compile
OpenGL seems to be missing. And I don't find it in the usual suspect

This is a known issue. You can find a workaround here:


This and some more useful info are in this CentOS wiki:



Thanks Akemi. I did discover where the ghc_OpenGL files were. Here's the
There is a missing kernel file and perhaps a problem in the kernel source.

Trying to install the virtual box extensions I ran across a misleading
error message about OpenGL not compiling. The machine I tried it on first
had OpenGL missing. I finally figured out it had never been configued for
epel. Half the problem was solved. But I got the same error. I traced back
to the build error:
        echo;                                                           \
         echo "  ERROR: Kernel configuration is invalid.";               \
         echo "         include/linux/autoconf.h or
include/config/auto.conf are missing.";      \
         echo "         Run 'make oldconfig && make prepare' on kernel
src to fix it.";  \

So to save time I went looking for the kernel source and attempted
make oldconfig and make prepare. The latter failed. I am either missing
something interesting or the kernel source is missing something

[jdow@sl6 2.6.32-431.5.1.el6.x86_64]$ sudo make oldconfig
scripts/kconfig/conf -o arch/x86/Kconfig
# configuration written to .config
[jdow@sl6 2.6.32-431.5.1.el6.x86_64]$ sudo make prepare
scripts/kconfig/conf -s arch/x86/Kconfig
   CHK     include/linux/version.h
   CHK     include/linux/utsrelease.h
   SYMLINK include/asm -> include/asm-x86
make[1]: *** No rule to make target `missing-syscalls'.  Stop.
make: *** [prepare0] Error 2
[jdow@sl6 2.6.32-431.5.1.el6.x86_64]$

So there may be two bugs here.

First the kernel-devel includes do not have the autoconf file.

Second trying to make prepare fails. (So does trying a subsequent "make

Do you have the kernel-devel package installed at all?  I'd try that
before doing manual kernel builds.  I believe that

And btw ... don't compile things as root (unless explicitly told to by
documentation).  That can completely mess up things, even though the
kernel is probably one of the more safer packages to build.  Doing 'make
install', however, requires root privileges.  But wait for root access
until this point.

Kernel-devel is installed as are all the other required items. Somehow I got
one of the two virtual machines to work. The other is still semi-unhappy. The
3D stuff won't compile, still.

The information Akemi posted is what guided me towards the solution.

Re actually compiling the kernel I'm a tad reluctant to do that. But going
through make prep is no problem. The process has changed a little since the
last time I compiled a kernel to make sure a driver I wanted was installed.
I even contributed the fixes to the kernel that made the driver work right,
since I was the one of the designers for the data the driver had to parse
in order to work right.


Reply via email to