Paul's recent dialogue about PS/2 keyboard in SeaBIOS reminds me that
I am also suffering PS/2 keyboard issues on three mainboards that I am
having with coreboot/SeaBIOS combo and need to ask here.

The boards are P2B-LS, P3B-F and P8Z77-M all from Asus. The last one
I'm doing a new port that is currently under review at coreboot.

On those boards I almost never got PS/2 keyboard to work before my
Linux kernel (4.4.14, soon 5.4.x) finishes booting and I get login
prompt. Only on P3B-F it would work intermittently earlier. USB
keyboards always worked right away. The PS/2 Keyboards I'm using are
two pieces of classic: IBM Model M and the first Microsoft Natural.

I am using SeaBIOS 1.13.0 which already carries commit dbf9dd27f which
described and should have fixed the issue I'm having. I also tried
tweaking with the PS/2 keyboard "spinup" timeout from 0 to 500 to 2500
to 3500ms with no noticeable difference. Now I'm stumped.

SeaBIOS mailing list --
To unsubscribe send an email to

Reply via email to