[jira] [Commented] (FLINK-14050) Refactor YarnClusterDescriptor inheritance

2019-09-17 Thread Aljoscha Krettek (Jira)


[ 
https://issues.apache.org/jira/browse/FLINK-14050?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16931244#comment-16931244
 ] 

Aljoscha Krettek commented on FLINK-14050:
--

I think it's fine to simplify the class hierarchy, yes.

> Refactor YarnClusterDescriptor inheritance
> --
>
> Key: FLINK-14050
> URL: https://issues.apache.org/jira/browse/FLINK-14050
> Project: Flink
>  Issue Type: Sub-task
>  Components: Client / Job Submission, Command Line Client
>Affects Versions: 1.10.0
>Reporter: TisonKun
>Priority: Major
> Fix For: 1.10.0
>
>
> Currently, the inheritance looks like
> {{AbstractYarnClusterDescriptor}}
> -> {{YarnClusterDescriptor}}
> -> {{TestingYarnClusterDescriptor}}
> -> {{NonDeployingYarnClusterDescriptor}}
> ->-> {{NonDeployingDetachedYarnClusterDescriptor}}
> With an investigation, I find
> 1. {{AbstractYarnClusterDescriptor}} is introduced for migration purpose and 
> no need any more.
> 2. {{TestingYarnClusterDescriptor}} is redundant and can be replaced directly 
> with {{YarnClusterDescriptor}}.
> 3. Some methods like {{#createYarnClusterClient}} have parameters that never 
> used, which are for historical reasons.
> Thus, I propose we refactor {{YarnClusterDescriptor}} inheritance 
> {{YarnClusterDescriptor}}
> -> {{NonDeployingYarnClusterDescriptor}}
> ->-> {{NonDeployingDetachedYarnClusterDescriptor}}
> and also methods remove unused parameters.
> CC [~kkl0u] [~aljoscha] [~till.rohrmann]



--
This message was sent by Atlassian Jira
(v8.3.2#803003)


[jira] [Commented] (FLINK-14050) Refactor YarnClusterDescriptor inheritance

2019-09-17 Thread TisonKun (Jira)


[ 
https://issues.apache.org/jira/browse/FLINK-14050?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16931142#comment-16931142
 ] 

TisonKun commented on FLINK-14050:
--

I will start progress in hours if there is no other concerns here.

> Refactor YarnClusterDescriptor inheritance
> --
>
> Key: FLINK-14050
> URL: https://issues.apache.org/jira/browse/FLINK-14050
> Project: Flink
>  Issue Type: Sub-task
>  Components: Client / Job Submission, Command Line Client
>Affects Versions: 1.10.0
>Reporter: TisonKun
>Priority: Major
> Fix For: 1.10.0
>
>
> Currently, the inheritance looks like
> {{AbstractYarnClusterDescriptor}}
> -> {{YarnClusterDescriptor}}
> -> {{TestingYarnClusterDescriptor}}
> -> {{NonDeployingYarnClusterDescriptor}}
> ->-> {{NonDeployingDetachedYarnClusterDescriptor}}
> With an investigation, I find
> 1. {{AbstractYarnClusterDescriptor}} is introduced for migration purpose and 
> no need any more.
> 2. {{TestingYarnClusterDescriptor}} is redundant and can be replaced directly 
> with {{YarnClusterDescriptor}}.
> 3. Some methods like {{#createYarnClusterClient}} have parameters that never 
> used, which are for historical reasons.
> Thus, I propose we refactor {{YarnClusterDescriptor}} inheritance 
> {{YarnClusterDescriptor}}
> -> {{NonDeployingYarnClusterDescriptor}}
> ->-> {{NonDeployingDetachedYarnClusterDescriptor}}
> and also methods remove unused parameters.
> CC [~kkl0u] [~aljoscha] [~till.rohrmann]



--
This message was sent by Atlassian Jira
(v8.3.2#803003)