[jira] [Commented] (YARN-6873) Moving logging APIs over to slf4j in hadoop-yarn-server-applicationhistoryservice

2017-08-07 Thread Wenxin He (JIRA)

[ 
https://issues.apache.org/jira/browse/YARN-6873?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16116141#comment-16116141
 ] 

Wenxin He commented on YARN-6873:
-

Verified +1: 
I added {{EWMA}}  to {{log4j.rootLogger}} in log4j.properties
{noformat}
log4j.rootLogger=${hadoop.root.logger}, EventCounter, EWMA
{noformat}
, restarted ApplicationHistoryServer and found "Errors/Warnings" link in the 
web http://:8188/applicationhistory.

BTW: 
The issue we broke in [^YARN-6873.003.patch] may not be YARN-2901. YARN-3511 
introduced the code that we broke,  am I right? 

> Moving logging APIs over to slf4j in 
> hadoop-yarn-server-applicationhistoryservice
> -
>
> Key: YARN-6873
> URL: https://issues.apache.org/jira/browse/YARN-6873
> Project: Hadoop YARN
>  Issue Type: Sub-task
>Reporter: Yeliang Cang
>Assignee: Yeliang Cang
> Attachments: YARN-6873.001.patch, YARN-6873.002.patch, 
> YARN-6873.003.patch, YARN-6873.004.patch
>
>




--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

-
To unsubscribe, e-mail: yarn-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: yarn-issues-h...@hadoop.apache.org



[jira] [Commented] (YARN-6873) Moving logging APIs over to slf4j in hadoop-yarn-server-applicationhistoryservice

2017-08-04 Thread Wenxin He (JIRA)

[ 
https://issues.apache.org/jira/browse/YARN-6873?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16113991#comment-16113991
 ] 

Wenxin He commented on YARN-6873:
-

[~Cyl], since HADOOP-14706 is commited, would you use the helper method 
{{isLog4jLogger}} in your patch?

> Moving logging APIs over to slf4j in 
> hadoop-yarn-server-applicationhistoryservice
> -
>
> Key: YARN-6873
> URL: https://issues.apache.org/jira/browse/YARN-6873
> Project: Hadoop YARN
>  Issue Type: Sub-task
>Reporter: Yeliang Cang
>Assignee: Yeliang Cang
> Attachments: YARN-6873.001.patch, YARN-6873.002.patch, 
> YARN-6873.003.patch
>
>




--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

-
To unsubscribe, e-mail: yarn-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: yarn-issues-h...@hadoop.apache.org



[jira] [Commented] (YARN-6873) Moving logging APIs over to slf4j in hadoop-yarn-server-applicationhistoryservice

2017-08-01 Thread Wenxin He (JIRA)

[ 
https://issues.apache.org/jira/browse/YARN-6873?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16108458#comment-16108458
 ] 

Wenxin He commented on YARN-6873:
-

Is it a good idea to add a helper method in hadoop-common to determine whether 
the LOG is Log4j implement like this?

{noformat}
  public static boolean isLog4jLogger(Class clazz) {
if (clazz == null) {
  return false;
}
Logger log = LoggerFactory.getLogger(clazz);
return log instanceof Log4jLoggerAdapter;
  }
{noformat}

In this way, we do not have to care of which adapter we use and prevent us from 
such bugs.

> Moving logging APIs over to slf4j in 
> hadoop-yarn-server-applicationhistoryservice
> -
>
> Key: YARN-6873
> URL: https://issues.apache.org/jira/browse/YARN-6873
> Project: Hadoop YARN
>  Issue Type: Sub-task
>Reporter: Yeliang Cang
>Assignee: Yeliang Cang
> Attachments: YARN-6873.001.patch, YARN-6873.002.patch, 
> YARN-6873.003.patch
>
>




--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

-
To unsubscribe, e-mail: yarn-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: yarn-issues-h...@hadoop.apache.org



[jira] [Commented] (YARN-6873) Moving logging APIs over to slf4j in hadoop-yarn-server-applicationhistoryservice

2017-07-31 Thread Wenxin He (JIRA)

[ 
https://issues.apache.org/jira/browse/YARN-6873?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16107298#comment-16107298
 ] 

Wenxin He commented on YARN-6873:
-

Looks good to me!

> Moving logging APIs over to slf4j in 
> hadoop-yarn-server-applicationhistoryservice
> -
>
> Key: YARN-6873
> URL: https://issues.apache.org/jira/browse/YARN-6873
> Project: Hadoop YARN
>  Issue Type: Sub-task
>Reporter: Yeliang Cang
>Assignee: Yeliang Cang
> Attachments: YARN-6873.001.patch, YARN-6873.002.patch, 
> YARN-6873.003.patch
>
>




--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

-
To unsubscribe, e-mail: yarn-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: yarn-issues-h...@hadoop.apache.org



[jira] [Commented] (YARN-6873) Moving logging APIs over to slf4j in hadoop-yarn-server-applicationhistoryservice

2017-07-30 Thread Wenxin He (JIRA)

[ 
https://issues.apache.org/jira/browse/YARN-6873?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16106792#comment-16106792
 ] 

Wenxin He commented on YARN-6873:
-

Mostly looks good to me, except some minor nits: 

# checkstyle warnings: All Indentation and LineLength warnings can be fixed.
# checkstyle warnings: StaticVariableName warning can be fixed by making the 
LOG *final*.
# indentation level 6 would be better:
{noformat}
+  private static final Logger LOG =
+  LoggerFactory.getLogger(ApplicationHistoryClientService.class);
{noformat}
{noformat}
+  private static final Logger LOG =
+  LoggerFactory.getLogger(ApplicationHistoryManagerImpl.class);
{noformat}

> Moving logging APIs over to slf4j in 
> hadoop-yarn-server-applicationhistoryservice
> -
>
> Key: YARN-6873
> URL: https://issues.apache.org/jira/browse/YARN-6873
> Project: Hadoop YARN
>  Issue Type: Sub-task
>Reporter: Yeliang Cang
>Assignee: Yeliang Cang
> Attachments: YARN-6873.001.patch
>
>




--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

-
To unsubscribe, e-mail: yarn-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: yarn-issues-h...@hadoop.apache.org