Re: [PATCH] dt-bindings: gpio: rcar: Add DT binding for r8a774b1

2019-10-03 Thread Bartosz Golaszewski
pon., 23 wrz 2019 o 15:28 Biju Das napisał(a): > > Document Renesas' RZ/G2N (R8A774B1) GPIO blocks compatibility within the > relevant dt-bindings. > > Signed-off-by: Biju Das > --- > Documentation/devicetree/bindings/gpio/renesas,gpio-rcar.txt | 1 + > 1 file changed, 1 insertion(+) > > diff --

Re: [PATCH] i2c: add newly exported functions to the header, too

2019-06-25 Thread Bartosz Golaszewski
t i2c_adapter *adapter, u16 address); > + > extern struct i2c_client * > devm_i2c_new_dummy_device(struct device *dev, struct i2c_adapter *adap, u16 > address); > > -- > 2.19.1 > Ha! How about that? :) Reviewed-by: Bartosz Golaszewski

Re: [PATCH 0/2] gpio: em: Miscellaneous probe cleanups

2019-05-28 Thread Bartosz Golaszewski
pon., 27 maj 2019 o 14:40 Geert Uytterhoeven napisał(a): > > Hi Linus, Bartosz, > > This small series contains two cleanups for the GPIO driver for the > venerable Renesas EMMA Mobile EV2 SoC. > > These are compile-tested only, due to lack of hardware. > > Thanks! > > Geert Uytterhoeven (2

Re: [PATCH v8 3/3] mfd: da9063: occupy second I2C address, too

2019-05-17 Thread Bartosz Golaszewski
@@ static int da9063_i2c_probe(struct i2c_client *i2c, > return ret; > } > > + devm_i2c_new_dummy_device(&i2c->dev, i2c->adapter, i2c->addr + 1); > + > return da9063_device_init(da9063, i2c->irq); > } > > -- > 2.19.1 > Reviewed-by: Bartosz Golaszewski

Re: [PATCH v8 2/3] i2c: core: add device-managed version of i2c_new_dummy

2019-05-17 Thread Bartosz Golaszewski
inux/i2c.h > @@ -469,6 +469,9 @@ extern int i2c_probe_func_quick_read(struct i2c_adapter > *, unsigned short addr); > extern struct i2c_client * > i2c_new_dummy(struct i2c_adapter *adap, u16 address); > > +extern struct i2c_client * > +devm_i2c_new_dummy_device(struct device *dev, struct i2c_adapter *adap, u16 > address); > + > extern struct i2c_client * > i2c_new_secondary_device(struct i2c_client *client, > const char *name, > -- > 2.19.1 > Reviewed-by: Bartosz Golaszewski

Re: [PATCH v8 1/3] i2c: core: improve return value handling of i2c_new_device and i2c_new_dummy

2019-05-17 Thread Bartosz Golaszewski
t) ? NULL : ret; > } > EXPORT_SYMBOL_GPL(i2c_new_dummy); > > @@ -1000,9 +1048,9 @@ i2c_sysfs_new_device(struct device *dev, struct > device_attribute *attr, > info.flags |= I2C_CLIENT_SLAVE; > } > > - client = i2c_new_device(adap, &info); > - if (!client) > - return -EINVAL; > + client = i2c_new_client_device(adap, &info); > + if (IS_ERR(client)) > + return PTR_ERR(client); > > /* Keep track of the added device */ > mutex_lock(&adap->userspace_clients_lock); > -- > 2.19.1 > Reviewed-by: Bartosz Golaszewski

Re: [PATCH v2 1/2] dt-bindings: gpio: pca953x: Document onnn,cat9554

2019-03-22 Thread Bartosz Golaszewski
czw., 21 mar 2019 o 10:21 Geert Uytterhoeven napisał(a): > > The ON Semiconductor CAT9554 is a variant of the PCA953x GPIO expander, > with 8 GPIOs and interrupt functionality. > > Signed-off-by: Geert Uytterhoeven > --- > v2: > - Split DT binding doc and driver update in separate patches. > --

Re: [PATCH] gpio: pca953x: Add support for CAT9554

2019-03-21 Thread Bartosz Golaszewski
śr., 20 mar 2019 o 11:36 Geert Uytterhoeven napisał(a): > > The ON Semiconductor CAT9554 is a variant of the PCA953x GPIO expander, > with 8 GPIOs and interrupt functionality. > > Signed-off-by: Geert Uytterhoeven > --- > Documentation/devicetree/bindings/gpio/gpio-pca953x.txt | 1 + > drivers/g

Re: [PATCH] dt-bindings: at24: add Renesas R1EX24016

2019-03-21 Thread Bartosz Golaszewski
śr., 20 mar 2019 o 11:33 Geert Uytterhoeven napisał(a): > > Document the compatible value for the Renesas R1EX24128ASAS0A two-wire > serial interface EEPROM, so it can be used in DTS files without causing > checkpatch warnings. > > This is a 2 KiB EEPROM. The first 1 KiB can always be written, th

Re: [PATCH v7 0/3] i2c: improve i2c_new_{device|dummy}

2019-03-14 Thread Bartosz Golaszewski
śr., 13 mar 2019 o 22:19 Wolfram Sang napisał(a): > > > > No problem. Once you'll have these in your tree, could you provide me > > with an immutable branch and I'll try to dig it out for at24 for v5.2? > > Quoting my cover letter ;) > > === > > If the feedback is positive, then I plan to create a

Re: [PATCH v7 0/3] i2c: improve i2c_new_{device|dummy}

2019-03-13 Thread Bartosz Golaszewski
śr., 13 mar 2019 o 22:09 Wolfram Sang napisał(a): > > > > Wasn't there a patch using this new managed variant in at24 as well? > > My Lager board has no EEPROM, so I skipped that. I was more interested > in the core parts for now. > No problem. Once you'll have these in your tree, could you provi

Re: [PATCH v7 0/3] i2c: improve i2c_new_{device|dummy}

2019-03-13 Thread Bartosz Golaszewski
śr., 13 mar 2019 o 17:56 Wolfram Sang napisał(a): > > I recently remembered this old series because I needed to add a dummy to the > DA9063 driver, so I had a look at it. I am somewhat sorry for the long delay, > yet the overload of patches is something I am not really responsible for :/ > > Howev

Re: Requesting false output GPIO as IRQ

2019-02-27 Thread Bartosz Golaszewski
wt., 26 lut 2019 o 11:01 Geert Uytterhoeven napisał(a): > > Hi Linus, Bartosz, > > If request_irq() is called on an otherwise unused GPIO that was > incorrectly configured for output by the firmware, this fails with: > > gpio gpiochip2: (e6052000.gpio): gpiochip_lock_as_irq: tried to > flag a

Re: [PATCH] gpio: pca953x: Add wake-up support

2019-02-12 Thread Bartosz Golaszewski
wt., 12 lut 2019 o 15:17 Geert Uytterhoeven napisał(a): > > Implement the irq_set_wake() method in the (optional) irq_chip of the > GPIO expander, and propagate wake-up settings to the upstream interrupt > controller. This allows GPIOs connected to a PCA953X GPIO expander to > serve as wake-up so

Re: [PATCH] Documentation: gpio: driver: fix wire name for I2C

2019-01-17 Thread Bartosz Golaszewski
czw., 17 sty 2019 o 11:24 Geert Uytterhoeven napisał(a): > > On Thu, Jan 17, 2019 at 11:14 AM Wolfram Sang > wrote: > > Typo: the data line is called "SDA" not "SCA". > > > > Signed-off-by: Wolfram Sang > > Reviewed-by: Geert Uytterhoeven > Applied to for-next, thanks! Bart

Re: [PATCH 02/14] gpio: pca953x: Fix AI overflow on PCAL6524

2018-12-03 Thread Bartosz Golaszewski
is used for the Address Increment functionality. > > Trim the mask to 0x60 to match the datasheet and to prevent accidental > overwrite of the AI bit. > > Signed-off-by: Marek Vasut > Cc: Linus Walleij > Cc: Bartosz Golaszewski > --- > drivers/gpio/gpio-pca953x.c |

Re: [PATCH 01/14] gpio: pca953x: Deduplicate the bank_size

2018-12-03 Thread Bartosz Golaszewski
niedz., 2 gru 2018 o 20:36 Marek Vasut napisał(a): > > The bank_size = fls(...) code was duplicated in the driver 5 times, > pull it into separate function. > Shouldn't it be bank_shift in the commit message? Bart > Signed-off-by: Marek Vasut > Cc: Linus Walleij &g

Re: [PATCH 1/2] clocksource/drivers/ostm: Delay driver registration

2018-08-30 Thread Bartosz Golaszewski
2018-08-30 11:16 GMT+02:00 Daniel Lezcano : > > [Added Arnd Bergmann, Bartosz Golaszewski and Mark Brown] > > On 30/08/2018 10:48, Geert Uytterhoeven wrote: >> Hi Daniel, > > [ ... ] > >>> Yeah, I got this point. But it is the meaning of your sentence: "

Re: [PATCH v2 5/5] dt-bindings: at24: add bindings for Rohm BR24T01

2018-03-02 Thread Bartosz Golaszewski
2018-01-29 16:45 GMT+01:00 Ulrich Hecht : > Both manufacturer and name variant. > > Signed-off-by: Ulrich Hecht > --- > Documentation/devicetree/bindings/eeprom/at24.txt | 2 ++ > 1 file changed, 2 insertions(+) > > diff --git a/Documentation/devicetree/bindings/eeprom/at24.txt > b/Documentation

Re: [PATCH v2 5/5] dt-bindings: at24: add bindings for Rohm BR24T01

2018-02-04 Thread Bartosz Golaszewski
2018-02-05 7:07 GMT+01:00 Rob Herring : > On Mon, Jan 29, 2018 at 04:45:48PM +0100, Ulrich Hecht wrote: >> Both manufacturer and name variant. >> >> Signed-off-by: Ulrich Hecht >> --- >> Documentation/devicetree/bindings/eeprom/at24.txt | 2 ++ >> 1 file changed, 2 insertions(+) > > Reviewed-by:

Re: [PATCH v2 5/5] dt-bindings: at24: add bindings for Rohm BR24T01

2018-02-02 Thread Bartosz Golaszewski
2018-01-30 11:44 GMT+01:00 Wolfram Sang : > On Mon, Jan 29, 2018 at 04:45:48PM +0100, Ulrich Hecht wrote: >> Both manufacturer and name variant. >> >> Signed-off-by: Ulrich Hecht > > Reviewed-by: Wolfram Sang > Acked-by: Bartosz Golaszewski

Re: [PATCH] dt-bindings: i2c: eeprom: Add Renesas R1EX24128

2017-11-27 Thread Bartosz Golaszewski
h has nothing to do with the bindings in eeprom.txt. Acked-in-advance-by: Bartosz Golaszewski Thanks, Bartosz