[PATCH v11 8/8] PCI: endpoint: Remove "core_init_notifier" flag

2024-03-26 Thread Manivannan Sadhasivam
"core_init_notifier" flag is set by the glue drivers requiring refclk from the host to complete the DWC core initialization. Also, those drivers will send a notification to the EPF drivers once the initialization is fully completed using the pci_epc_init_notify() API. Only then, the EPF drivers wil

[PATCH v11 7/8] PCI: dwc: ep: Call dw_pcie_ep_init_registers() API directly from all glue drivers

2024-03-26 Thread Manivannan Sadhasivam
Currently, dw_pcie_ep_init_registers() API is directly called by the glue drivers requiring active refclk from host. But for the other drivers, it is getting called implicitly by dw_pcie_ep_init(). This is due to the fact that this API initializes DWC EP specific registers and that requires an acti

[PATCH v11 6/8] PCI: dwc: ep: Rename dw_pcie_ep_init_complete() to dw_pcie_ep_init_registers()

2024-03-26 Thread Manivannan Sadhasivam
The goal of the dw_pcie_ep_init_complete() API is to initialize the DWC specific registers post registering the controller with the EP framework. But the naming doesn't reflect its functionality and causes confusion. So, let's rename it to dw_pcie_ep_init_registers() to make it clear that it initi

[PATCH v11 5/8] PCI: dwc: ep: Introduce dw_pcie_ep_cleanup() API for drivers supporting PERST#

2024-03-26 Thread Manivannan Sadhasivam
For DWC glue drivers supporting PERST# (currently Qcom and Tegra194), some of the DWC resources like eDMA should be cleaned up during the PERST# assert time. So let's introduce a dw_pcie_ep_cleanup() API that could be called by these drivers to cleanup the DWC specific resources. Currently, it jus

[PATCH v11 4/8] PCI: dwc: ep: Rename dw_pcie_ep_exit() to dw_pcie_ep_deinit()

2024-03-26 Thread Manivannan Sadhasivam
dw_pcie_ep_exit() API is undoing what the dw_pcie_ep_init() API has done already (at least partly). But the API name dw_pcie_ep_exit() is not quite reflecting that. So let's rename it to dw_pcie_ep_deinit() to make the purpose of this API clear. This also aligns with the DWC host driver. Reviewed-

[PATCH v11 3/8] PCI: dwc: ep: Remove deinit() callback from struct dw_pcie_ep_ops

2024-03-26 Thread Manivannan Sadhasivam
deinit() callback was solely introduced for the pcie-rcar-gen4 driver where it is used to do platform specific resource deallocation. And this callback is called right at the end of the dw_pcie_ep_exit() API. So it doesn't matter whether it is called within or outside of dw_pcie_ep_exit() API. So

[PATCH v11 2/8] PCI: dwc: ep: Add Kernel-doc comments for APIs

2024-03-26 Thread Manivannan Sadhasivam
All of the APIs are missing the Kernel-doc comments. Hence, add them. Reviewed-by: Frank Li Reviewed-by: Niklas Cassel Signed-off-by: Manivannan Sadhasivam --- drivers/pci/controller/dwc/pcie-designware-ep.c | 77 + 1 file changed, 77 insertions(+) diff --git a/drivers

[PATCH v11 1/8] PCI: dwc: ep: Fix DBI access failure for drivers requiring refclk from host

2024-03-26 Thread Manivannan Sadhasivam
The DWC glue drivers requiring an active reference clock from the PCIe host for initializing their PCIe EP core, set a flag called 'core_init_notifier' to let DWC driver know that these drivers need a special attention during initialization. In these drivers, access to the hw registers (like DBI) b

[PATCH v11 0/8] PCI: dwc: ep: Fix DBI access failure for drivers requiring refclk from host

2024-03-26 Thread Manivannan Sadhasivam
Hello, This series is the continuation of previous work by Vidya Sagar [1] to fix the issues related to accessing DBI register space before completing the core initialization in some EP platforms like Tegra194/234 and Qcom EP. Since Vidya is busy, I took over the series based on his consent (off-

[PATCH] Add static_key_feature_checks_initialized flag

2024-03-26 Thread Nicholas Miehlbradt
JUMP_LABEL_FEATURE_CHECK_DEBUG used static_key_initialized to determine whether {cpu,mmu}_has_feature() was used before static keys were initialized. However, {cpu,mmu}_has_feature() should not be used before setup_feature_keys() is called. As static_key_initalized is set much earlier during boot t

Re: [PATCHv3 pci-next 1/2] PCI/AER: correctable error message as KERN_INFO

2024-03-26 Thread Ethan Zhao
On 3/27/2024 5:17 AM, Bjorn Helgaas wrote: On Tue, Mar 26, 2024 at 09:39:54AM +0800, Ethan Zhao wrote: On 3/25/2024 6:15 PM, Xi Ruoyao wrote: On Mon, 2024-03-25 at 16:45 +0800, Ethan Zhao wrote: On 3/25/2024 1:19 AM, Xi Ruoyao wrote: On Mon, 2023-09-18 at 14:39 -0500, Bjorn Helgaas wrote: On

Re: [PATCH v11 0/5]arm64: add ARCH_HAS_COPY_MC support

2024-03-26 Thread Tong Tiangen
Hi Mark: Kindly ping... Thanks, Tong. 在 2024/2/7 21:21, Tong Tiangen 写道: With the increase of memory capacity and density, the probability of memory error also increases. The increasing size and density of server RAM in data centers and clouds have shown increased uncorrectable memory

Re: [PATCH 0/9] enabled -Wformat-truncation for clang

2024-03-26 Thread Jakub Kicinski
On Tue, 26 Mar 2024 23:37:59 +0100 Arnd Bergmann wrote: > I hope that the patches can get picked up by platform maintainers > directly, so the final patch can go in later on. platform == subsystem? :)

[PATCH 8/9] ALSA: aoa: avoid false-positive format truncation warning

2024-03-26 Thread Arnd Bergmann
From: Arnd Bergmann clang warns about what it interprets as a truncated snprintf: sound/aoa/soundbus/i2sbus/core.c:171:6: error: 'snprintf' will always be truncated; specified size is 6, but format string expands to at least 7 [-Werror,-Wformat-truncation-non-kprintf] The actual problem here

[PATCH 0/9] enabled -Wformat-truncation for clang

2024-03-26 Thread Arnd Bergmann
From: Arnd Bergmann With randconfig build testing, I found only eight files that produce warnings with clang when -Wformat-truncation is enabled. This means we can just turn it on by default rather than only enabling it for "make W=1". Unfortunately, gcc produces a lot more warnings when the opt

Re: [PATCHv3 pci-next 1/2] PCI/AER: correctable error message as KERN_INFO

2024-03-26 Thread Bjorn Helgaas
On Tue, Mar 26, 2024 at 09:39:54AM +0800, Ethan Zhao wrote: > On 3/25/2024 6:15 PM, Xi Ruoyao wrote: > > On Mon, 2024-03-25 at 16:45 +0800, Ethan Zhao wrote: > > > On 3/25/2024 1:19 AM, Xi Ruoyao wrote: > > > > On Mon, 2023-09-18 at 14:39 -0500, Bjorn Helgaas wrote: > > > > > On Mon, Sep 18, 2023 a

Re: [PATCH 1/1] x86/elf: Add a new .note section containing Xfeatures information to x86 core files

2024-03-26 Thread Balasubrmanian, Vignesh
On 3/14/2024 10:09 PM, Dave Hansen wrote: Caution: This message originated from an External Source. Use proper caution when opening attachments, clicking links, or responding. On 3/14/24 09:29, Borislav Petkov wrote: That argument breaks down a bit on the flags though: xc.xfeat_flags

Re: [PATCH 14/64] i2c: cpm: reword according to newest specification

2024-03-26 Thread Andi Shyti
Hi Wolfram, ... > @@ -570,7 +570,7 @@ static int cpm_i2c_setup(struct cpm_i2c *cpm) > out_8(&cpm->i2c_reg->i2brg, brg); > > out_8(&cpm->i2c_reg->i2mod, 0x00); > - out_8(&cpm->i2c_reg->i2com, I2COM_MASTER); /* Master mode */ > + out_8(&cpm->i2c_reg->i2com, I2COM_MASTER);

Re: Appropriate liburcu cache line size for Power

2024-03-26 Thread Segher Boessenkool
On Tue, Mar 26, 2024 at 06:19:38PM +1100, Michael Ellerman wrote: > Mathieu Desnoyers writes: > The ISA doesn't specify the cache line size, other than it is smaller > than a page. It also says it is "aligned". Nowhere is it said what an aligned size is, but it seems clear it has to be a power o

Re: [PATCH v3 0/5] ASoC: fsl: Support register and unregister rpmsg sound card through remoteproc

2024-03-26 Thread Mark Brown
On Mon, 11 Mar 2024 20:13:44 +0900, Chancel Liu wrote: > echo /lib/firmware/fw.elf > /sys/class/remoteproc/remoteproc0/firmware > (A) echo start > /sys/class/remoteproc/remoteproc0/state > (B) echo stop > /sys/class/remoteproc/remoteproc0/state > > The rpmsg sound card is registered in (

Re: [RFC PATCH 1/8] mm: Provide pagesize to pmd_populate()

2024-03-26 Thread Jason Gunthorpe
On Mon, Mar 25, 2024 at 07:05:01PM +, Christophe Leroy wrote: > Not looked into details yet, but I guess so. > > By the way there is a wiki dedicated to huge pages on powerpc, you can > have a look at it here : > https://github.com/linuxppc/wiki/wiki/Huge-pages , maybe you'll find > good i

Re: Appropriate liburcu cache line size for Power

2024-03-26 Thread Mathieu Desnoyers
On 2024-03-26 03:19, Michael Ellerman wrote: Mathieu Desnoyers writes: Hi, Hi Mathieu, In the powerpc architecture support within the liburcu project [1] we have a cache line size defined as 256 bytes with the following comment: /* Include size of POWER5+ L3 cache lines: 256 bytes */ #defi

Re: [PATCH v3 00/12] mm/gup: Unify hugetlb, part 2

2024-03-26 Thread Jason Gunthorpe
On Mon, Mar 25, 2024 at 02:58:48PM -0400, Peter Xu wrote: > > This remark would be a little easier to understand if you refer to > > hugetlb_walk() not huge_pte_offset() - the latter is only used to > > implement hugetlb_walk() and isn't removed by this series, while a > > single hugetlb_walk() wa

Re: [PATCH v2 3/6] mm/mm_init.c: add new function calc_nr_all_pages()

2024-03-26 Thread Baoquan He
On 03/26/24 at 08:57am, Mike Rapoport wrote: > Hi Baoquan, > > On Mon, Mar 25, 2024 at 10:56:43PM +0800, Baoquan He wrote: > > This is a preparation to calculate nr_kernel_pages and nr_all_pages, > > both of which will be used later in alloc_large_system_hash(). > > > > nr_all_pages counts up all

Re: [PATCH v1 1/1] ASoC: fsl: imx-es8328: Remove leftover gpio initialisation

2024-03-26 Thread Mark Brown
On Mon, 25 Mar 2024 21:13:41 +0200, Andy Shevchenko wrote: > The gpio field is not used anymore, remove the leftover. > This also fixes the compilation error after the ... > > Applied to https://git.kernel.org/pub/scm/linux/kernel/git/broonie/sound.git for-next Thanks! [1/1] ASoC: fsl: imx

Re: [PATCH 1/1] x86/elf: Add a new .note section containing Xfeatures information to x86 core files

2024-03-26 Thread Balasubrmanian, Vignesh
IMHO you should split the changes to replace ARCH_HAVE_EXTRA_ELF_NOTES with CONFIG_ARCH_HAVE_EXTRA_ELF_NOTES into a lead-up patch. cheers Thanks for the input and i will take care in next version. regards, vigneshbalu.

Re: [PATCH 1/1] x86/elf: Add a new .note section containing Xfeatures information to x86 core files

2024-03-26 Thread Balasubrmanian, Vignesh
Otherwise looks reasonable, though I see Dave has feedback to address too. :) Thanks for working on this! -Kees Thank you for the review. I will address all this on next version. thanks, vigneshbalu. -- Kees Cook

[PATCH v4] arch/powerpc/kvm: Add support for reading VPA counters for pseries guests

2024-03-26 Thread Gautam Menghani
PAPR hypervisor has introduced three new counters in the VPA area of LPAR CPUs for KVM L2 guest (see [1] for terminology) observability - 2 for context switches from host to guest and vice versa, and 1 counter for getting the total time spent inside the KVM guest. Add a tracepoint that enables read

Re: [PATCH 3/3] tools/perf/arch/powerc: Add get_arch_regnum for powerpc

2024-03-26 Thread Tiezhu Yang
Hi Athira and Namhyung, On 03/09/2024 03:25 PM, Athira Rajeev wrote: The function get_dwarf_regnum() returns a DWARF register number from a register name string. This calls arch specific function get_arch_regnum to return register number for corresponding arch. Add mappings for register name to

Re: Appropriate liburcu cache line size for Power

2024-03-26 Thread Michael Ellerman
Mathieu Desnoyers writes: > Hi, Hi Mathieu, > In the powerpc architecture support within the liburcu project [1] > we have a cache line size defined as 256 bytes with the following > comment: > > /* Include size of POWER5+ L3 cache lines: 256 bytes */ > #define CAA_CACHE_LINE_SIZE 256 > > I

Re: [PATCH v2 3/3] powerpc/code-patching: Restore 32-bit patching performance

2024-03-26 Thread Christophe Leroy
Le 25/03/2024 à 23:48, Benjamin Gray a écrit : > The new open/close abstraction makes it more difficult for a > compiler to optimise. This causes 10% worse performance on > ppc32 as in [1]. Restoring the page alignment mask and inlining > the helpers allows the compiler to better reason about the