Re: [PATCH 00/19] [Set 2] Rid W=1 warnings from GPU

2020-11-07 Thread Sam Ravnborg
On Sat, Nov 07, 2020 at 06:41:38PM +, Lee Jones wrote:
> On Sat, 07 Nov 2020, Sam Ravnborg wrote:
> 
> > Hi Christian.
> > 
> > > I'm not sure if we want to do some of the suggested changes to radeon.
> > 
> > All patches for radeon looks good to me except "drm/radeon/radeon: Move
> > prototype into shared header".
> 
> Was that the one where the prototype needs moving to radeon.h?
Yes,

Sam
___
amd-gfx mailing list
amd-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/amd-gfx


Re: [PATCH 00/19] [Set 2] Rid W=1 warnings from GPU

2020-11-07 Thread Sam Ravnborg
Hi Christian.

> I'm not sure if we want to do some of the suggested changes to radeon.

All patches for radeon looks good to me except "drm/radeon/radeon: Move
prototype into shared header".

Acked-by: Sam Ravnborg 
from me to have them applied (except the shared header one).
I can reply to the individual patches if you like.

Sam
___
amd-gfx mailing list
amd-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/amd-gfx


Re: [PATCH 17/19] drm/radeon/radeon_kms: Fix misnaming of 'radeon_info_ioctl's dev param

2020-11-07 Thread Sam Ravnborg
Hi Lee,

On Fri, Nov 06, 2020 at 09:49:47PM +, Lee Jones wrote:
> Fixes the following W=1 kernel build warning(s):
> 
>  drivers/gpu/drm/radeon/radeon_kms.c:226: warning: Function parameter or 
> member 'dev' not described in 'radeon_info_ioctl'
>  drivers/gpu/drm/radeon/radeon_kms.c:226: warning: Excess function parameter 
> 'rdev' description in 'radeon_info_ioctl'
> 
> Cc: Alex Deucher 
> Cc: "Christian König" 
> Cc: David Airlie 
> Cc: Daniel Vetter 
> Cc: amd-gfx@lists.freedesktop.org
> Cc: dri-de...@lists.freedesktop.org
> Signed-off-by: Lee Jones 
> ---
>  drivers/gpu/drm/radeon/radeon_kms.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/drivers/gpu/drm/radeon/radeon_kms.c 
> b/drivers/gpu/drm/radeon/radeon_kms.c
> index 0d8fbabffcead..21c206795c364 100644
> --- a/drivers/gpu/drm/radeon/radeon_kms.c
> +++ b/drivers/gpu/drm/radeon/radeon_kms.c
> @@ -213,7 +213,7 @@ static void radeon_set_filp_rights(struct drm_device *dev,
>  /**
>   * radeon_info_ioctl - answer a device specific request.
>   *
> - * @rdev: radeon device pointer
> + * @dev: radeon device pointer
>   * @data: request object
>   * @filp: drm filp
>   *

Delete all the kernel-doc annotation as we do not pull this file into
the kernel-doc anyway.

Keep the /* Answer a device specific request */ part.

At least thats what I see as the best way to deal with it.

Sam
___
amd-gfx mailing list
amd-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/amd-gfx


Re: [PATCH 10/19] drm/radeon/radeon: Move prototype into shared header

2020-11-07 Thread Sam Ravnborg
Hi Lee,

On Fri, Nov 06, 2020 at 09:49:40PM +, Lee Jones wrote:
> Unfortunately, a suitable one didn't already exist.
> 
> Fixes the following W=1 kernel build warning(s):
> 
>  drivers/gpu/drm/radeon/radeon_device.c:637:6: warning: no previous prototype 
> for ‘radeon_device_is_virtual’ [-Wmissing-prototypes]
>  637 | bool radeon_device_is_virtual(void)
>  | ^~~~
> 
> Cc: Alex Deucher 
> Cc: "Christian König" 
> Cc: David Airlie 
> Cc: Daniel Vetter 
> Cc: Sumit Semwal 
> Cc: amd-gfx@lists.freedesktop.org
> Cc: dri-de...@lists.freedesktop.org
> Cc: linux-me...@vger.kernel.org
> Cc: linaro-mm-...@lists.linaro.org
> Signed-off-by: Lee Jones 
> ---
>  drivers/gpu/drm/radeon/radeon_device.c |  1 +
>  drivers/gpu/drm/radeon/radeon_device.h | 32 ++
>  drivers/gpu/drm/radeon/radeon_drv.c|  3 +--
>  3 files changed, 34 insertions(+), 2 deletions(-)
>  create mode 100644 drivers/gpu/drm/radeon/radeon_device.h

Other public functions in radeon_device.c have their prototype in
radeon.h - for example radeon_is_px()

Add radeon_device_is_virtual() there so we avoiid this new header.

Sam
___
amd-gfx mailing list
amd-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/amd-gfx


Re: [PATCH 00/19] [Set 2] Rid W=1 warnings from GPU

2020-11-07 Thread Christian König

Well that's quite a patch set.

First of all can you separate this a bit more by driver? I'm assuming we 
maintainers are supposed to pick that up and apply it.


radeon and amdgpu can stick together since that is mostly Alex and me, 
but I'm not sure if we want to do some of the suggested changes to radeon.


Going to pick up the single TTM change for upstreaming.

Thanks,
Christian.

Am 06.11.20 um 22:49 schrieb Lee Jones:

This set is part of a larger effort attempting to clean-up W=1
kernel builds, which are currently overwhelmingly riddled with
niggly little warnings.

There are 5000 warnings to work through.  It will take a couple more
sets.  Although, ("drm/amd/display/dc/basics/fixpt31_32: Move
variables to where they're used") does take care of 2000 of them!

Lee Jones (19):
   drm/ttm/ttm_range_manager: Demote non-conformant kernel-doc header
   drm/r128/ati_pcigart: Source file headers are not good candidates for
 kernel-doc
   drm/selftests/test-drm_dp_mst_helper: Move
 'sideband_msg_req_encode_decode' onto the heap
   drm/mga/mga_dma: Demote kernel-doc abusers to standard comment blocks
   drm/mga/mga_state: Remove unused variable 'buf_priv'
   drm/radeon/atom: Move prototype into shared location
   drm/radeon/radeon_kms: Include header containing our own prototypes
   drm/omapdrm/omap_gem: Fix misnamed and missing parameter descriptions
   drm/omapdrm/omap_dmm_tiler: Demote abusive use of kernel-doc format
   drm/radeon/radeon: Move prototype into shared header
   drm/radeon/radeon_drv: Source file headers are not good candidates for
 kernel-doc
   drm/amd/display/dc/basics/fixpt31_32: Move variables to where they're
 used
   drm/radeon/radeon_drv: Move prototypes to a shared headerfile
   drm/amd/amdgpu/amdgpu_device: Provide documentation for 'reg_addr'
 params
   drm/radeon: Move prototypes to shared header
   drm/amd/amdgpu/amdgpu_kms: Remove 'struct drm_amdgpu_info_device
 dev_info' from the stack
   drm/radeon/radeon_kms: Fix misnaming of 'radeon_info_ioctl's dev param
   drm/radeon/atombios_crtc: Remove description of non-existent function
 param 'encoder'
   drm/v3d/v3d_drv: Remove unused static variable 'v3d_v3d_pm_ops'

  drivers/gpu/drm/amd/amdgpu/amdgpu_device.c|   2 +
  drivers/gpu/drm/amd/amdgpu/amdgpu_kms.c   | 104 +-
  .../drm/amd/display/dc/basics/fixpt31_32.c|   5 +
  .../gpu/drm/amd/display/include/fixed31_32.h  |   6 -
  drivers/gpu/drm/mga/mga_dma.c |  10 +-
  drivers/gpu/drm/mga/mga_state.c   |   2 -
  drivers/gpu/drm/omapdrm/omap_dmm_tiler.c  |   6 +-
  drivers/gpu/drm/omapdrm/omap_gem.c|   3 +-
  drivers/gpu/drm/r128/ati_pcigart.c|   2 +-
  drivers/gpu/drm/radeon/atom.h |   6 +
  drivers/gpu/drm/radeon/atombios_crtc.c|   1 -
  drivers/gpu/drm/radeon/atombios_encoders.c|   4 -
  drivers/gpu/drm/radeon/radeon.h   |   6 +
  drivers/gpu/drm/radeon/radeon_device.c|   1 +
  drivers/gpu/drm/radeon/radeon_device.h|  32 ++
  drivers/gpu/drm/radeon/radeon_display.c   |   4 -
  drivers/gpu/drm/radeon/radeon_drv.c   |  11 +-
  drivers/gpu/drm/radeon/radeon_drv.h   |   7 ++
  drivers/gpu/drm/radeon/radeon_kms.c   |   3 +-
  .../drm/selftests/test-drm_dp_mst_helper.c|  11 +-
  drivers/gpu/drm/ttm/ttm_range_manager.c   |   2 +-
  drivers/gpu/drm/v3d/v3d_drv.c |  36 --
  22 files changed, 138 insertions(+), 126 deletions(-)
  create mode 100644 drivers/gpu/drm/radeon/radeon_device.h

Cc: Alex Deucher 
Cc: amd-gfx@lists.freedesktop.org
Cc: Andy Gross 
Cc: by 
Cc: Christian Koenig 
Cc: "Christian König" 
Cc: Daniel Vetter 
Cc: David Airlie 
Cc: dri-de...@lists.freedesktop.org
Cc: Eric Anholt 
Cc: Faith 
Cc: Gareth Hughes 
Cc: Harry Wentland 
Cc: Huang Rui 
Cc: Jeff Hartmann 
Cc: Keith Whitwell 
Cc: Leo Li 
Cc: linaro-mm-...@lists.linaro.org
Cc: linux-me...@vger.kernel.org
Cc: Philipp Zabel 
Cc: Rob Clark 
Cc: Rob Clark 
Cc: Sumit Semwal 
Cc: Tomi Valkeinen 


___
amd-gfx mailing list
amd-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/amd-gfx