Re: [PATCH] D24526: [Release notes] Mention readability-container-size-empty improvements

2016-09-14 Thread Phabricator via cfe-commits
This revision was automatically updated to reflect the committed changes.
Closed by commit rL281510: [Release notes] Mention 
readability-container-size-empty improvements. (authored by eugenezelenko).

Changed prior to commit:
  https://reviews.llvm.org/D24526?vs=71250=71394#toc

Repository:
  rL LLVM

https://reviews.llvm.org/D24526

Files:
  clang-tools-extra/trunk/docs/ReleaseNotes.rst

Index: clang-tools-extra/trunk/docs/ReleaseNotes.rst
===
--- clang-tools-extra/trunk/docs/ReleaseNotes.rst
+++ clang-tools-extra/trunk/docs/ReleaseNotes.rst
@@ -95,6 +95,11 @@
   Warns about the performance overhead arising from concatenating strings using
   the ``operator+``, instead of ``operator+=``.
 
+- `readability-container-size-empty
+  
`_
 check
+  supports arbitrary containers with with suitable ``empty()`` and ``size()``
+  methods.
+
 - New `readability-misplaced-array-index
   
`_
 check
 


Index: clang-tools-extra/trunk/docs/ReleaseNotes.rst
===
--- clang-tools-extra/trunk/docs/ReleaseNotes.rst
+++ clang-tools-extra/trunk/docs/ReleaseNotes.rst
@@ -95,6 +95,11 @@
   Warns about the performance overhead arising from concatenating strings using
   the ``operator+``, instead of ``operator+=``.
 
+- `readability-container-size-empty
+  `_ check
+  supports arbitrary containers with with suitable ``empty()`` and ``size()``
+  methods.
+
 - New `readability-misplaced-array-index
   `_ check
 
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits


Re: [PATCH] D24526: [Release notes] Mention readability-container-size-empty improvements

2016-09-14 Thread Eugene Zelenko via cfe-commits
Eugene.Zelenko added inline comments.


Comment at: docs/ReleaseNotes.rst:94
@@ +93,3 @@
+  
`_
 check
+  supports arbitrary containers with ``empty()`` and ``size()`` methods.
+

alexfh wrote:
> The wording is a bit too broad. We should somehow hint that the methods are 
> not just arbitrary. Maybe "with suitable ``size()`` and ``empty()`` methods"?
Will fix on commit. **Suitable** sounds good enough since link to documentation 
is provided, where more details could be found.


Repository:
  rL LLVM

https://reviews.llvm.org/D24526



___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits


Re: [PATCH] D24526: [Release notes] Mention readability-container-size-empty improvements

2016-09-14 Thread Alexander Kornienko via cfe-commits
alexfh accepted this revision.
alexfh added a comment.
This revision is now accepted and ready to land.

LG with a nit.



Comment at: docs/ReleaseNotes.rst:94
@@ +93,3 @@
+  
`_
 check
+  supports arbitrary containers with ``empty()`` and ``size()`` methods.
+

The wording is a bit too broad. We should somehow hint that the methods are not 
just arbitrary. Maybe "with suitable ``size()`` and ``empty()`` methods"?


Repository:
  rL LLVM

https://reviews.llvm.org/D24526



___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits


[PATCH] D24526: [Release notes] Mention readability-container-size-empty improvements

2016-09-13 Thread Eugene Zelenko via cfe-commits
Eugene.Zelenko created this revision.
Eugene.Zelenko added reviewers: alexfh, omtcyfz.
Eugene.Zelenko added a subscriber: cfe-commits.
Eugene.Zelenko set the repository for this revision to rL LLVM.

Repository:
  rL LLVM

https://reviews.llvm.org/D24526

Files:
  docs/ReleaseNotes.rst

Index: docs/ReleaseNotes.rst
===
--- docs/ReleaseNotes.rst
+++ docs/ReleaseNotes.rst
@@ -89,6 +89,10 @@
   Warns about the performance overhead arising from concatenating strings using
   the ``operator+``, instead of ``operator+=``.
 
+- `readability-container-size-empty
+  
`_
 check
+  supports arbitrary containers with ``empty()`` and ``size()`` methods.
+
 - New `readability-misplaced-array-index
   
`_
 check
 


Index: docs/ReleaseNotes.rst
===
--- docs/ReleaseNotes.rst
+++ docs/ReleaseNotes.rst
@@ -89,6 +89,10 @@
   Warns about the performance overhead arising from concatenating strings using
   the ``operator+``, instead of ``operator+=``.
 
+- `readability-container-size-empty
+  `_ check
+  supports arbitrary containers with ``empty()`` and ``size()`` methods.
+
 - New `readability-misplaced-array-index
   `_ check
 
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits