Re: [c-nsp] 7600 Rate Limiting Output

2010-01-31 Thread Rob Shakir

On 31 Jan 2010, at 03:18, Kevin Warwashana wrote:

 I was able to use the below configuration and it appears to max out the
 connection pretty close to 26mb.  I did have to tinker with the queue size
 since the default (3300+) would allow traffic to exceed and a size of 5
 didn't seem to work very well.
 
 policy-map 26MB-OUTPUT
  class class-default
shape average 2600
queue-limit 100 packets
bandwidth 26000
 
 You mentioned configure a shaper at class-default, with an attached
 service-policy which I believe would be adding a service policy to the
 policy map, but got:

What I meant was this:

policy-map RJS-TEST
  class class-default
shape average 3000
   service-policy RJS-CHILD-TEST
!
policy-map RJS-CHILD-TEST
  class class-default
   police cir 2600 conform-action transmit exceed-action drop
!

Which is something that one can apply on SIP-400:

7600#sh run int giga1/0/0.4011
Building configuration...

Current configuration : 239 bytes
!
interface GigabitEthernet1/0/0.4011
 encapsulation dot1Q 4011
 ip address 192.168.88.42 255.255.255.0
 ip vrf forwarding RJS-TEST
 shutdown
 service-policy input POLICY-SET-IP-DSCP-DEFAULT
 service-policy output RJS-TEST
end

Out of interest - what IOS are you running on the 7600 in question?

Kind regards,
Rob

-- 
Rob Shakir  r...@eng.gxn.net
Network Development EngineerGX Networks/Vialtus Solutions
ddi: +44208 587 6077mob: +44797 155 4098
pgp: 0xc07e6deb nic-hdl: RJS-RIPE

This email is subject to: http://www.vialtus.com/disclaimer.html

___
cisco-nsp mailing list  cisco-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/


Re: [c-nsp] 7600 Rate Limiting Output

2010-01-30 Thread Pavel Skovajsa
Hi,

It looks like you are trying to configure this on the WS-X67xy cards,
which are basically the LAN/DC cards taken from 6500. These cards have
very limited QoS capabilities as they are targetted for LAN/DC
segment, not for service provider. Hence you cannot expect MUCH.

If you need sophisticated QoS you should buy ES20 or ES+
(http://www.cisco.com/en/US/prod/collateral/routers/ps368/data_sheet_c78-549419.html).

To give you some hope, many people have fallen into this trap (me
for example, there are much much more things the WS-X67xy cards cannot
do), and it is simply due to not reading the documentation before
buying. There is a nice explanation of the 6500/7600 hardware based
QoS on http://www.networkworld.com/community/node/43764

-pavel







On Thu, Jan 28, 2010 at 11:10 PM, Kevin Warwashana kev...@telnetww.com wrote:
 Anyone have a suggestion/comment?

 Thanks,
 Kevin


 -Original Message-
 From: cisco-nsp-boun...@puck.nether.net
 [mailto:cisco-nsp-boun...@puck.nether.net] On Behalf Of Kevin Warwashana
 Sent: Saturday, January 23, 2010 10:47 PM
 To: cisco-nsp@puck.nether.net
 Subject: [c-nsp] 7600 Rate Limiting Output

 I was curious what is the best way to limit bandwidth in/out with policy
 maps.  I can apply this inbound on a subinterface:



 policy-map 26MB-INPUT

  class class-default

   police rate 2600 bps

     conform-action transmit

     exceed-action drop



 but the below won't apply in the outbound direction:



 policy-map 26MB-OUTPUT

  class class-default

   police rate 2600 bps

     conform-action transmit

     exceed-action drop



 Gives me:



 int gig4/0/0.8

 service-policy output 26MB-OUTPUT

 Police and strict priority must be configured together for egress QOS.

 Invalid feature combination for the class class-default

 Configuration failed



 Any help would be appreciated!  I miss the rate-limiting command from 7200
 routers :).



 Kevin

 ___
 cisco-nsp mailing list  cisco-...@puck.nether.net
 https://puck.nether.net/mailman/listinfo/cisco-nsp
 archive at http://puck.nether.net/pipermail/cisco-nsp/


 ___
 cisco-nsp mailing list  cisco-...@puck.nether.net
 https://puck.nether.net/mailman/listinfo/cisco-nsp
 archive at http://puck.nether.net/pipermail/cisco-nsp/

___
cisco-nsp mailing list  cisco-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/


Re: [c-nsp] 7600 Rate Limiting Output

2010-01-30 Thread Kevin Warwashana
Actually I am using a SIP-600 with a SPA-5X1GE.

Kevin


-Original Message-
From: Pavel Skovajsa [mailto:pavel.skova...@gmail.com] 
Sent: Saturday, January 30, 2010 1:08 PM
To: Kevin Warwashana
Cc: cisco-nsp@puck.nether.net
Subject: Re: [c-nsp] 7600 Rate Limiting Output

Hi,

It looks like you are trying to configure this on the WS-X67xy cards,
which are basically the LAN/DC cards taken from 6500. These cards have
very limited QoS capabilities as they are targetted for LAN/DC
segment, not for service provider. Hence you cannot expect MUCH.

If you need sophisticated QoS you should buy ES20 or ES+
(http://www.cisco.com/en/US/prod/collateral/routers/ps368/data_sheet_c78-549
419.html).

To give you some hope, many people have fallen into this trap (me
for example, there are much much more things the WS-X67xy cards cannot
do), and it is simply due to not reading the documentation before
buying. There is a nice explanation of the 6500/7600 hardware based
QoS on http://www.networkworld.com/community/node/43764

-pavel







On Thu, Jan 28, 2010 at 11:10 PM, Kevin Warwashana kev...@telnetww.com
wrote:
 Anyone have a suggestion/comment?

 Thanks,
 Kevin


 -Original Message-
 From: cisco-nsp-boun...@puck.nether.net
 [mailto:cisco-nsp-boun...@puck.nether.net] On Behalf Of Kevin Warwashana
 Sent: Saturday, January 23, 2010 10:47 PM
 To: cisco-nsp@puck.nether.net
 Subject: [c-nsp] 7600 Rate Limiting Output

 I was curious what is the best way to limit bandwidth in/out with policy
 maps.  I can apply this inbound on a subinterface:



 policy-map 26MB-INPUT

  class class-default

   police rate 2600 bps

     conform-action transmit

     exceed-action drop



 but the below won't apply in the outbound direction:



 policy-map 26MB-OUTPUT

  class class-default

   police rate 2600 bps

     conform-action transmit

     exceed-action drop



 Gives me:



 int gig4/0/0.8

 service-policy output 26MB-OUTPUT

 Police and strict priority must be configured together for egress QOS.

 Invalid feature combination for the class class-default

 Configuration failed



 Any help would be appreciated!  I miss the rate-limiting command from 7200
 routers :).



 Kevin

 ___
 cisco-nsp mailing list  cisco-...@puck.nether.net
 https://puck.nether.net/mailman/listinfo/cisco-nsp
 archive at http://puck.nether.net/pipermail/cisco-nsp/


 ___
 cisco-nsp mailing list  cisco-...@puck.nether.net
 https://puck.nether.net/mailman/listinfo/cisco-nsp
 archive at http://puck.nether.net/pipermail/cisco-nsp/



___
cisco-nsp mailing list  cisco-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/


Re: [c-nsp] 7600 Rate Limiting Output

2010-01-30 Thread Pavel Skovajsa
well, that kind of makes my earlier post not relevant.

Anyway, noticed that you are trying to police egress. I don't know
about SIP-600 but normally this is not possible - you need to SHAPE.
So change police to shape.

-pavel

On Sat, Jan 30, 2010 at 7:29 PM, Kevin Warwashana kev...@telnetww.com wrote:
 Actually I am using a SIP-600 with a SPA-5X1GE.

 Kevin


 -Original Message-
 From: Pavel Skovajsa [mailto:pavel.skova...@gmail.com]
 Sent: Saturday, January 30, 2010 1:08 PM
 To: Kevin Warwashana
 Cc: cisco-nsp@puck.nether.net
 Subject: Re: [c-nsp] 7600 Rate Limiting Output

 Hi,

 It looks like you are trying to configure this on the WS-X67xy cards,
 which are basically the LAN/DC cards taken from 6500. These cards have
 very limited QoS capabilities as they are targetted for LAN/DC
 segment, not for service provider. Hence you cannot expect MUCH.

 If you need sophisticated QoS you should buy ES20 or ES+
 (http://www.cisco.com/en/US/prod/collateral/routers/ps368/data_sheet_c78-549
 419.html).

 To give you some hope, many people have fallen into this trap (me
 for example, there are much much more things the WS-X67xy cards cannot
 do), and it is simply due to not reading the documentation before
 buying. There is a nice explanation of the 6500/7600 hardware based
 QoS on http://www.networkworld.com/community/node/43764

 -pavel







 On Thu, Jan 28, 2010 at 11:10 PM, Kevin Warwashana kev...@telnetww.com
 wrote:
 Anyone have a suggestion/comment?

 Thanks,
 Kevin


 -Original Message-
 From: cisco-nsp-boun...@puck.nether.net
 [mailto:cisco-nsp-boun...@puck.nether.net] On Behalf Of Kevin Warwashana
 Sent: Saturday, January 23, 2010 10:47 PM
 To: cisco-nsp@puck.nether.net
 Subject: [c-nsp] 7600 Rate Limiting Output

 I was curious what is the best way to limit bandwidth in/out with policy
 maps.  I can apply this inbound on a subinterface:



 policy-map 26MB-INPUT

  class class-default

   police rate 2600 bps

     conform-action transmit

     exceed-action drop



 but the below won't apply in the outbound direction:



 policy-map 26MB-OUTPUT

  class class-default

   police rate 2600 bps

     conform-action transmit

     exceed-action drop



 Gives me:



 int gig4/0/0.8

 service-policy output 26MB-OUTPUT

 Police and strict priority must be configured together for egress QOS.

 Invalid feature combination for the class class-default

 Configuration failed



 Any help would be appreciated!  I miss the rate-limiting command from 7200
 routers :).



 Kevin

 ___
 cisco-nsp mailing list  cisco-...@puck.nether.net
 https://puck.nether.net/mailman/listinfo/cisco-nsp
 archive at http://puck.nether.net/pipermail/cisco-nsp/


 ___
 cisco-nsp mailing list  cisco-...@puck.nether.net
 https://puck.nether.net/mailman/listinfo/cisco-nsp
 archive at http://puck.nether.net/pipermail/cisco-nsp/



 ___
 cisco-nsp mailing list  cisco-...@puck.nether.net
 https://puck.nether.net/mailman/listinfo/cisco-nsp
 archive at http://puck.nether.net/pipermail/cisco-nsp/

___
cisco-nsp mailing list  cisco-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/


Re: [c-nsp] 7600 Rate Limiting Output

2010-01-30 Thread Rob Shakir

On 24 Jan 2010, at 03:46, Kevin Warwashana wrote:
 
 int gig4/0/0.8
 
 service-policy output 26MB-OUTPUT
 
 Police and strict priority must be configured together for egress QOS.
 
 Invalid feature combination for the class class-default
 
 Configuration failed

This looks like what you see on ES-20 when trying a similar configuration. It 
implies that one must configure an LLQ to be able to police. Therefore to 
achieve this, you can do:

policy-map POLICY-POLICE-26MBPS-OUT
 class class-default
  police cir 2600 conform-action transmit exceed-action drop
  ! forced to be an llq
  priority
 !
!

However, interestingly, the configuration that you supplied appears to be 
configurable on SIP-400 w/ SPA-2x1GE:

7600#sh policy-map RJS-TEST

  Policy Map RJS-TEST
Class class-default
 police rate 2600 bps
   conform-action transmit
   exceed-action drop

7600#sh run int giga1/0/0.4011
Building configuration...

Current configuration : 239 bytes
!
interface GigabitEthernet1/0/0.4011
 encapsulation dot1Q 4011
 ip address 192.168.88.42 255.255.255.0
 ip vrf forwarding RJS-TEST
 service-policy input POLICY-SET-IP-DSCP-DEFAULT
 service-policy output RJS-TEST
end

This may be due to the fact that the datasheet for SIP-400 [0] says that it 
supports egress queueing, whereas SIP-600 [1] states only egress shaping. 
If you don't have inter-op requirements, can you configure it as a shaper with 
a very short queue length, so that you start to emulate policing?

Alternatively, it might be worth checking whether you can configure a shaper at 
class-default, with an attached service-policy that can then police under this.

Hope this helps!

Kind regards,
Rob

[0]: 
http://www.cisco.com/en/US/prod/collateral/routers/ps368/product_data_sheet0900aecd8027c9e6.html
[1]: 
http://www.cisco.com/en/US/prod/collateral/routers/ps368/product_data_sheet0900aecd8033998f_ps708_Products_Data_Sheet.html


-- 
Rob Shakir  r...@eng.gxn.net
Network Development EngineerGX Networks/Vialtus Solutions
ddi: +44208 587 6077mob: +44797 155 4098
pgp: 0xc07e6deb nic-hdl: RJS-RIPE

This email is subject to: http://www.vialtus.com/disclaimer.html




___
cisco-nsp mailing list  cisco-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/


[c-nsp] 7600 Rate Limiting Output

2010-01-23 Thread Kevin Warwashana
I was curious what is the best way to limit bandwidth in/out with policy
maps.  I can apply this inbound on a subinterface:

 

policy-map 26MB-INPUT

  class class-default

   police rate 2600 bps

 conform-action transmit

 exceed-action drop

 

but the below won't apply in the outbound direction:

 

policy-map 26MB-OUTPUT

  class class-default

   police rate 2600 bps

 conform-action transmit

 exceed-action drop

 

Gives me:

 

int gig4/0/0.8

service-policy output 26MB-OUTPUT

Police and strict priority must be configured together for egress QOS.

Invalid feature combination for the class class-default

Configuration failed

 

Any help would be appreciated!  I miss the rate-limiting command from 7200
routers :).

 

Kevin

___
cisco-nsp mailing list  cisco-nsp@puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/