Re: Review Request 72021: ATLAS-3590: Hive hook should ignore capturing lineage for temporary tables in CTAS queries

2020-01-17 Thread Ashutosh Mestry via Review Board

---
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/72021/#review219325
---


Ship it!




Ship It!

- Ashutosh Mestry


On Jan. 17, 2020, 12:54 a.m., Sarath Subramanian wrote:
> 
> ---
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/72021/
> ---
> 
> (Updated Jan. 17, 2020, 12:54 a.m.)
> 
> 
> Review request for atlas, Ashutosh Mestry, Madhan Neethiraj, Mandar Ambawane, 
> mayank jain, Nixon Rodrigues, and Sidharth Mishra.
> 
> 
> Bugs: ATLAS-3590
> https://issues.apache.org/jira/browse/ATLAS-3590
> 
> 
> Repository: atlas
> 
> 
> Description
> ---
> 
> Atlas hive hook ignores capturing metadata for temporary tables in CREATE 
> queries. Similarly it should ignore capturing lineage for temporary tables in 
> CTAS queries
> 
> 
> Diffs
> -
> 
>   addons/hive-bridge/src/main/java/org/apache/atlas/hive/hook/HiveHook.java 
> 5b1f61b63 
>   
> addons/hive-bridge/src/main/java/org/apache/atlas/hive/hook/events/BaseHiveEvent.java
>  425be5952 
>   
> addons/hive-bridge/src/main/java/org/apache/atlas/hive/hook/events/CreateHiveProcess.java
>  82df57650 
> 
> 
> Diff: https://reviews.apache.org/r/72021/diff/1/
> 
> 
> Testing
> ---
> 
> validated manually hive hook is not sending lineage for temporary table.
> 
> Precommit: 
> https://builds.apache.org/view/A/view/Atlas/job/PreCommit-ATLAS-Build-Test/1606/console
> 
> 
> Thanks,
> 
> Sarath Subramanian
> 
>



Re: Review Request 72025: ATLAS-3591: Improve user-defined properties search

2020-01-17 Thread Ashutosh Mestry via Review Board

---
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/72025/#review219324
---




repository/src/main/java/org/apache/atlas/discovery/SearchProcessor.java
Line 94 (original), 98 (patched)


Revert the change since only qualifiers are changed.



repository/src/main/java/org/apache/atlas/discovery/SearchProcessor.java
Line 112 (original), 116 (patched)


Revert to earlier version for better readability.



repository/src/main/java/org/apache/atlas/discovery/SearchProcessor.java
Lines 521 (patched)


Prefer: StringUtils.isNotEmpty(key)


- Ashutosh Mestry


On Jan. 17, 2020, 9:04 p.m., Sarath Subramanian wrote:
> 
> ---
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/72025/
> ---
> 
> (Updated Jan. 17, 2020, 9:04 p.m.)
> 
> 
> Review request for atlas, Ashutosh Mestry, Madhan Neethiraj, Mandar Ambawane, 
> mayank jain, Nixon Rodrigues, and Sidharth Mishra.
> 
> 
> Bugs: ATLAS-3591
> https://issues.apache.org/jira/browse/ATLAS-3591
> 
> 
> Repository: atlas
> 
> 
> Description
> ---
> 
> User-defined properties search is enabled in system attribute search. This 
> Jira is improve the usability of the user-defined properties search.
> 
> For. e.g
> 
> "entityFilters": { "condition": "AND", "criterion": [ { "attributeName": 
> "__customAttributes", "operator": "contains", "attributeValue": "key2=value2" 
> } ] }
> 
> 
> Diffs
> -
> 
>   repository/src/main/java/org/apache/atlas/discovery/SearchProcessor.java 
> 278b97faa 
>   webapp/src/test/java/org/apache/atlas/web/adapters/TestEntitiesREST.java 
> b2c1d4aa5 
> 
> 
> Diff: https://reviews.apache.org/r/72025/diff/1/
> 
> 
> Testing
> ---
> 
> Updated unit tests to test this improvement.
> 
> Precommit: 
> https://builds.apache.org/view/A/view/Atlas/job/PreCommit-ATLAS-Build-Test/1609/console
> 
> 
> Thanks,
> 
> Sarath Subramanian
> 
>



Review Request 72025: ATLAS-3591: Improve user-defined properties search

2020-01-17 Thread Sarath Subramanian

---
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/72025/
---

Review request for atlas, Ashutosh Mestry, Madhan Neethiraj, Mandar Ambawane, 
mayank jain, Nixon Rodrigues, and Sidharth Mishra.


Bugs: ATLAS-3591
https://issues.apache.org/jira/browse/ATLAS-3591


Repository: atlas


Description
---

User-defined properties search is enabled in system attribute search. This Jira 
is improve the usability of the user-defined properties search.

For. e.g

"entityFilters": { "condition": "AND", "criterion": [ { "attributeName": 
"__customAttributes", "operator": "contains", "attributeValue": "key2=value2" } 
] }


Diffs
-

  repository/src/main/java/org/apache/atlas/discovery/SearchProcessor.java 
278b97faa 
  webapp/src/test/java/org/apache/atlas/web/adapters/TestEntitiesREST.java 
b2c1d4aa5 


Diff: https://reviews.apache.org/r/72025/diff/1/


Testing
---

Updated unit tests to test this improvement.

Precommit: 
https://builds.apache.org/view/A/view/Atlas/job/PreCommit-ATLAS-Build-Test/1609/console


Thanks,

Sarath Subramanian



[jira] [Updated] (ATLAS-3591) Improve user-defined properties search

2020-01-17 Thread Sarath Subramanian (Jira)


 [ 
https://issues.apache.org/jira/browse/ATLAS-3591?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Sarath Subramanian updated ATLAS-3591:
--
Attachment: ATLAS-3591.001.patch

> Improve user-defined properties search
> --
>
> Key: ATLAS-3591
> URL: https://issues.apache.org/jira/browse/ATLAS-3591
> Project: Atlas
>  Issue Type: Task
>  Components:  atlas-core
>Affects Versions: 2.0.0
>Reporter: Sarath Subramanian
>Assignee: Sarath Subramanian
>Priority: Major
> Fix For: 2.1.0
>
> Attachments: ATLAS-3591.001.patch
>
>
> User-defined properties search is enabled in system attribute search. This 
> Jira is improve the usability of the user-defined properties search.
>  
> For. e.g
>  
> {code:java}
> "entityFilters": { "condition": "AND", "criterion": [ { "attributeName": 
> "__customAttributes", "operator": "contains", "attributeValue": "key2=value2" 
> } ] }
> {code}



--
This message was sent by Atlassian Jira
(v8.3.4#803005)


[jira] [Updated] (ATLAS-3591) Improve user-defined properties search

2020-01-17 Thread Sarath Subramanian (Jira)


 [ 
https://issues.apache.org/jira/browse/ATLAS-3591?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Sarath Subramanian updated ATLAS-3591:
--
Description: 
User-defined properties search is enabled in system attribute search. This Jira 
is improve the usability of the user-defined properties search.

 

For. e.g

 
{code:java}
"entityFilters": { "condition": "AND", "criterion": [ { "attributeName": 
"__customAttributes", "operator": "contains", "attributeValue": "key2=value2" } 
] }
{code}

  was:
User-defined properties search is enabled in system attribute search. This Jira 
is improve the usability of the user-defined properties search.

 

For. e.g

 
"entityFilters": {
    "condition": "AND",
    "criterion": [
      {
        "attributeName" : "*__customAttributes*",
        "operator"      : "*contains*",
        "attributeValue": *"key2=value2"*
      }
    ]
  }


> Improve user-defined properties search
> --
>
> Key: ATLAS-3591
> URL: https://issues.apache.org/jira/browse/ATLAS-3591
> Project: Atlas
>  Issue Type: Task
>  Components:  atlas-core
>Affects Versions: 2.0.0
>Reporter: Sarath Subramanian
>Assignee: Sarath Subramanian
>Priority: Major
> Fix For: 2.1.0
>
>
> User-defined properties search is enabled in system attribute search. This 
> Jira is improve the usability of the user-defined properties search.
>  
> For. e.g
>  
> {code:java}
> "entityFilters": { "condition": "AND", "criterion": [ { "attributeName": 
> "__customAttributes", "operator": "contains", "attributeValue": "key2=value2" 
> } ] }
> {code}



--
This message was sent by Atlassian Jira
(v8.3.4#803005)


[jira] [Created] (ATLAS-3591) Improve user-defined properties search

2020-01-17 Thread Sarath Subramanian (Jira)
Sarath Subramanian created ATLAS-3591:
-

 Summary: Improve user-defined properties search
 Key: ATLAS-3591
 URL: https://issues.apache.org/jira/browse/ATLAS-3591
 Project: Atlas
  Issue Type: Task
  Components:  atlas-core
Affects Versions: 2.0.0
Reporter: Sarath Subramanian
Assignee: Sarath Subramanian
 Fix For: 2.1.0


User-defined properties search is enabled in system attribute search. This Jira 
is improve the usability of the user-defined properties search.

 

For. e.g

 
"entityFilters": {
    "condition": "AND",
    "criterion": [
      {
        "attributeName" : "*__customAttributes*",
        "operator"      : "*contains*",
        "attributeValue": *"key2=value2"*
      }
    ]
  }



--
This message was sent by Atlassian Jira
(v8.3.4#803005)


[jira] [Commented] (ATLAS-3588) Export API - Update documentation

2020-01-17 Thread ASF subversion and git services (Jira)


[ 
https://issues.apache.org/jira/browse/ATLAS-3588?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=17018274#comment-17018274
 ] 

ASF subversion and git services commented on ATLAS-3588:


Commit 225272397ba3e44ed0a0bcf79c2bf5ddd04949e4 in atlas's branch 
refs/heads/branch-2.0 from nikhilbonte
[ https://gitbox.apache.org/repos/asf?p=atlas.git;h=2252723 ]

ATLAS-3588 Export API- Update documentation

Signed-off-by: Ashutosh Mestry 


> Export API - Update documentation
> -
>
> Key: ATLAS-3588
> URL: https://issues.apache.org/jira/browse/ATLAS-3588
> Project: Atlas
>  Issue Type: Bug
>Reporter: Nikhil Bonte
>Assignee: Nikhil Bonte
>Priority: Major
> Attachments: ATLAS-3588-Export-API-Update-documentation.patch
>
>
> This is update to export API documentation at 
> [https://atlas.apache.org/#/ExportAPI]



--
This message was sent by Atlassian Jira
(v8.3.4#803005)


[jira] [Commented] (ATLAS-3559) Asset Type Definition: Add attribute displayName & userDescription

2020-01-17 Thread ASF subversion and git services (Jira)


[ 
https://issues.apache.org/jira/browse/ATLAS-3559?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=17018275#comment-17018275
 ] 

ASF subversion and git services commented on ATLAS-3559:


Commit b07fa3bb8f6cab0dfd3d9119cfcf4184c2c12209 in atlas's branch 
refs/heads/branch-2.0 from Ashutosh Mestry
[ https://gitbox.apache.org/repos/asf?p=atlas.git;h=b07fa3b ]

ATLAS-3559: Additional attributes (displayName & userDescription) to Asset.


> Asset Type Definition: Add attribute displayName & userDescription
> --
>
> Key: ATLAS-3559
> URL: https://issues.apache.org/jira/browse/ATLAS-3559
> Project: Atlas
>  Issue Type: Improvement
>  Components:  atlas-core
>Affects Versions: 2.0.0
>Reporter: Nikhil Bonte
>Assignee: Nikhil Bonte
>Priority: Major
> Fix For: 2.1.0
>
> Attachments: 
> ATLAS-3559-Add-attribute-displayName-in-Asset-typeDe.patch, 
> ATLAS-3559-Additional-attributes-to-Asset.patch
>
>
> *Background*
> Currently _name_ and _description_ get set as part of setting technical 
> metadata. Example, Hive hook sets these values as part of posting hook 
> messages. Once this data is available within Atlas, there is no way to 
> override these attributes. It would not make sense to change these values 
> since these are set as part of initial ingest.
> *Solution*
> Add _displayName_ and _userDescription_ to _Asset_ optional attributes. 
> Later, UI can be developed to let end user update these properties 
> interactively.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)


[jira] [Updated] (ATLAS-3559) Asset Type Definition: Add attribute displayName & userDescription

2020-01-17 Thread Sarath Subramanian (Jira)


 [ 
https://issues.apache.org/jira/browse/ATLAS-3559?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Sarath Subramanian updated ATLAS-3559:
--
Component/s:  atlas-core

> Asset Type Definition: Add attribute displayName & userDescription
> --
>
> Key: ATLAS-3559
> URL: https://issues.apache.org/jira/browse/ATLAS-3559
> Project: Atlas
>  Issue Type: Improvement
>  Components:  atlas-core
>Affects Versions: 2.0.0
>Reporter: Nikhil Bonte
>Assignee: Nikhil Bonte
>Priority: Major
> Fix For: 2.1.0
>
> Attachments: 
> ATLAS-3559-Add-attribute-displayName-in-Asset-typeDe.patch, 
> ATLAS-3559-Additional-attributes-to-Asset.patch
>
>
> *Background*
> Currently _name_ and _description_ get set as part of setting technical 
> metadata. Example, Hive hook sets these values as part of posting hook 
> messages. Once this data is available within Atlas, there is no way to 
> override these attributes. It would not make sense to change these values 
> since these are set as part of initial ingest.
> *Solution*
> Add _displayName_ and _userDescription_ to _Asset_ optional attributes. 
> Later, UI can be developed to let end user update these properties 
> interactively.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)


[jira] [Updated] (ATLAS-3559) Asset Type Definition: Add attribute displayName & userDescription

2020-01-17 Thread Sarath Subramanian (Jira)


 [ 
https://issues.apache.org/jira/browse/ATLAS-3559?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Sarath Subramanian updated ATLAS-3559:
--
Affects Version/s: 2.0.0

> Asset Type Definition: Add attribute displayName & userDescription
> --
>
> Key: ATLAS-3559
> URL: https://issues.apache.org/jira/browse/ATLAS-3559
> Project: Atlas
>  Issue Type: Improvement
>Affects Versions: 2.0.0
>Reporter: Nikhil Bonte
>Assignee: Nikhil Bonte
>Priority: Major
> Attachments: 
> ATLAS-3559-Add-attribute-displayName-in-Asset-typeDe.patch, 
> ATLAS-3559-Additional-attributes-to-Asset.patch
>
>
> *Background*
> Currently _name_ and _description_ get set as part of setting technical 
> metadata. Example, Hive hook sets these values as part of posting hook 
> messages. Once this data is available within Atlas, there is no way to 
> override these attributes. It would not make sense to change these values 
> since these are set as part of initial ingest.
> *Solution*
> Add _displayName_ and _userDescription_ to _Asset_ optional attributes. 
> Later, UI can be developed to let end user update these properties 
> interactively.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)


[jira] [Updated] (ATLAS-3559) Asset Type Definition: Add attribute displayName & userDescription

2020-01-17 Thread Sarath Subramanian (Jira)


 [ 
https://issues.apache.org/jira/browse/ATLAS-3559?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Sarath Subramanian updated ATLAS-3559:
--
Fix Version/s: 2.1.0

> Asset Type Definition: Add attribute displayName & userDescription
> --
>
> Key: ATLAS-3559
> URL: https://issues.apache.org/jira/browse/ATLAS-3559
> Project: Atlas
>  Issue Type: Improvement
>Affects Versions: 2.0.0
>Reporter: Nikhil Bonte
>Assignee: Nikhil Bonte
>Priority: Major
> Fix For: 2.1.0
>
> Attachments: 
> ATLAS-3559-Add-attribute-displayName-in-Asset-typeDe.patch, 
> ATLAS-3559-Additional-attributes-to-Asset.patch
>
>
> *Background*
> Currently _name_ and _description_ get set as part of setting technical 
> metadata. Example, Hive hook sets these values as part of posting hook 
> messages. Once this data is available within Atlas, there is no way to 
> override these attributes. It would not make sense to change these values 
> since these are set as part of initial ingest.
> *Solution*
> Add _displayName_ and _userDescription_ to _Asset_ optional attributes. 
> Later, UI can be developed to let end user update these properties 
> interactively.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)