[ 
https://issues.apache.org/jira/browse/AVRO-2309?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

BELUGA BEHR updated AVRO-2309:
------------------------------
    Summary: Conversions.java - Use JDK Array Manipulations  (was: 
Conversions.java - Use Fill Method)

> Conversions.java - Use JDK Array Manipulations
> ----------------------------------------------
>
>                 Key: AVRO-2309
>                 URL: https://issues.apache.org/jira/browse/AVRO-2309
>             Project: Apache Avro
>          Issue Type: Improvement
>            Reporter: BELUGA BEHR
>            Priority: Trivial
>
> {code:java|title=Conversions.java}
>       for (int i = 0; i < bytes.length; i += 1) {
>         if (i < offset) {
>           bytes[i] = fillByte;
>         } else {
>           bytes[i] = unscaled[i - offset];
>         }
>       }
> {code}
> Improve readability with {{Arrays.fill}} method to fill the first {{offset}} 
> bytes and then copy over the remaining.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Reply via email to